Bug 41910 - Handle duplicate filesystem labels properly on upgrade.
Handle duplicate filesystem labels properly on upgrade.
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-22 16:33 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-22 16:33:13 EDT
Description of Problem: Prior to installing and upgrade from 7.0 to 7.1 on
SCSI based HP system, I made a mirror backup of /dev/sda onto /dev/sdc. 
Upgrade 'spotted' that /dev/sdc contained a bootable 
drive with O/S on it, asked (with radio buttons) which drive I wanted to
upgrade.  I chose /dev/sda and when upgrade was finished, all programs
(installed rpms) on /dev/sda were upgraded...BUT...the new 
kernel was placed on /dev/sdc anyway (but not /dev/sda) and its MBR (but
not /dev/sda) was updated.  This effectively left both /dev/sda and
/dev/sdc unbootable!  /dev/sda had new O/S but old kernel and MBR; /dev/sdc
had old O/S but new kernel and MBR...

This is just a report of bug to try and be helpful, I am not requesting any
assistance on this.

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Arjan van de Ven 2001-05-22 16:36:20 EDT
Thanks for the report.
I'm assigning it to the installer component.
Comment 2 Matt Wilson 2001-08-24 18:20:27 EDT
this is because the installer uses 'mount by label' to mount your filesystems. 
The last found label wins, so the "/" label on the sdc drive gets mounted.
Comment 3 Michael Fulbright 2002-03-26 12:27:53 EST
Deferred to future release.
Comment 4 Red Hat Bugzilla 2006-02-21 13:48:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.