Bug 419171 - RHEL5.2: Linux support for the architrectural pstate driver
RHEL5.2: Linux support for the architrectural pstate driver
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
high Severity high
: ---
: ---
Assigned To: Bhavna Sarathy
Martin Jenner
: FutureFeature, OtherQA
Depends On:
Blocks: 253746
  Show dependency treegraph
 
Reported: 2007-12-10 22:32 EST by Bhavna Sarathy
Modified: 2009-06-19 21:51 EDT (History)
9 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:03:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
linux architectural pstate patch (9.01 KB, patch)
2007-12-12 16:22 EST, Bhavna Sarathy
no flags Details | Diff
xen changes to support pstate changes (2.11 KB, patch)
2007-12-12 16:23 EST, Bhavna Sarathy
no flags Details | Diff

  None (edit)
Description Bhavna Sarathy 2007-12-10 22:32:52 EST
With the third generation Opteron parts, AMD switched to an
architecturally defined interface for PowerNow! that uses
different MSRs than previous versions.

This patch brings the PowerNow! driver up to match the mainline
Linux driver and provide support for all AMD parts that use
or will use the architectural pstate interface.

This request also includes the support in msr-index.h and traps.c
in the hypervisor for the new interface. 

Upstream links:
http://xenbits.xensource.com/xen-unstable.hg?rev/ddc9e6b2babb
http://xenbits.xensource.com/linux-2.6.18-xen.hg?rev/a37a8c474d8b
Comment 2 Bhavna Sarathy 2007-12-11 15:01:49 EST
Can I get a PM ACK please?
Comment 5 Bhavna Sarathy 2007-12-12 16:21:59 EST
Completed back porting the Linux Power Now! driver patches to add the pstate
bits and the corresponding Xen support.
Comment 6 Bhavna Sarathy 2007-12-12 16:22:37 EST
Created attachment 286201 [details]
linux architectural pstate patch
Comment 7 Bhavna Sarathy 2007-12-12 16:23:00 EST
Created attachment 286211 [details]
xen changes to support pstate changes
Comment 8 Bhavna Sarathy 2007-12-12 16:24:00 EST
Can I get some BZ ACKs please?  Thanks.
Comment 9 Rik van Riel 2007-12-12 16:28:32 EST
The patches look good to me.
Comment 10 Bhavna Sarathy 2007-12-17 16:13:42 EST
Posted patches on 12/17 to RHML, tested on barcelona systems.  Please provide PM
and QA ACK.

Bhavana
Comment 11 Bhavna Sarathy 2007-12-17 16:52:02 EST
Brew build:
http://brewweb.devel.redhat.com/brew/taskinfo?taskID=1083370

Testing:
Barcelona 2p/8c system - both bare metal and Xen tested with ondemand 
governor wattage change noted with a power meter.  Also usual userspace 
governor tests done. 

Further performance tests are always welcome. 

My patches are applied on top of Rik's patches and the RPMs in this build
have the full range of Power Now! Linux and Xen patches.
Comment 14 Don Zickus 2007-12-21 15:18:38 EST
in 2.6.18-62.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 16 John Poelstra 2008-03-20 23:59:13 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot1--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 17 John Poelstra 2008-04-02 17:39:57 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot3--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 18 John Poelstra 2008-04-09 18:45:40 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot4--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 19 Frank Arnold 2008-04-16 09:04:49 EDT
We ran a varity of tests for PowerNow! with Xen on different snapshots. The
box primarily used for those tests was a 2p/8c system. No functionality
issues were observed during those tests.

Further testing done on Snap4 bare metal:

System:
  Platform:  1P, Sahara
  Processor: Phenom 9600, B2I
  Memory:    6 GB

Test program:
  kernbench 0.42 with vanilla 2.6.18.8 sources

Test conditions:
  1 32-bit PAE install, cpuspeed enabled, governor ondemand
  2 32-bit PAE install, cpuspeed turned off
  3 64-bit install, cpuspeed enabled, governor ondemand
  4 64-bit install, cpuspeed turned off
  5 64-bit install, cpuspeed enabled, governor userspace

  Due to the lack of a power meter available for immediate use no power
  usage measurements were made during the tests, but this was already
  done as per comment #11. The frequency of all cores was monitored during
  the  tests.

Result:
  Numbers look good to me. Functionality is given.

Detailed results:
  Test 1
    Di 15. Apr 16:38:08 CEST 2008
    2.6.18-88.el5PAE
    Average Half load -j 3 Run (std deviation):
    Elapsed Time 123 (0)
    User Time 295 (0)
    System Time 74 (0)
    Percent CPU 299,8 (0,447214)
    Context Switches 31280 (114,182)
    Sleeps 22972,2 (47,6466)

    Average Optimal load -j 16 Run (std deviation):
    Elapsed Time 96,4 (0,547723)
    User Time 295 (0)
    System Time 73,1 (0,994429)
    Percent CPU 339,8 (42,1685)
    Context Switches 37688,2 (6756,49)
    Sleeps 25749,9 (2930,95)

    Average Maximal load -j Run (std deviation):
    Elapsed Time 94,8 (0,447214)
    User Time 293,6 (2,09762)
    System Time 72,4667 (1,24595)
    Percent CPU 353,467 (39,2899)
    Context Switches 36170,5 (5859,54)
    Sleeps 24242,9 (3226,08)

  Test 2:
    2.6.18-88.el5PAE
    Average Half load -j 3 Run (std deviation):
    Elapsed Time 118,8 (0,447214)
    User Time 286,4 (0,547723)
    System Time 70,4 (0,547723)
    Percent CPU 299,6 (0,547723)
    Context Switches 16364 (77,8621)
    Sleeps 22931,8 (60,3424)
 
    Average Optimal load -j 16 Run (std deviation):
    Elapsed Time 94,2 (0,447214)
    User Time 288,9 (2,68535)
    System Time 71,3 (1,05935)
    Percent CPU 341,4 (44,0712)
    Context Switches 23114,8 (7116,59)
    Sleeps 25553,4 (2769,47)
 
    Average Maximal load -j Run (std deviation):
    Elapsed Time 93,4 (0,894427)
    User Time 289 (2,17124)
    System Time 71,2 (0,861892)
    Percent CPU 355,267 (40,7702)
    Context Switches 21766,6 (6042,81)
    Sleeps 23999,2 (3183,47)

  Test 3:
    2.6.18-88.el5
    Average Half load -j 3 Run (std deviation):
    Elapsed Time 136,6 (0,547723)
    User Time 349,4 (0,547723)
    System Time 59 (0)
    Percent CPU 298,4 (0,547723)
    Context Switches 35130,2 (99,5927)
    Sleeps 28623,8 (78,2924)
 
    Average Optimal load -j 16 Run (std deviation):
    Elapsed Time 114 (0,707107)
    User Time 355,4 (6,3456)
    System Time 59,5 (0,527046)
    Percent CPU 333,5 (37,0232)
    Context Switches 43272,5 (8583,63)
    Sleeps 31446,2 (2978,59)
 
    Average Maximal load -j Run (std deviation):
    Elapsed Time 167,8 (80,3287)
    User Time 353,733 (6,47486)
    System Time 60,8667 (3,58303)
    Percent CPU 317,733 (67,8796)
    Context Switches 43134,1 (7429,4)
    Sleeps 34413,4 (9633,25)

  Test 4:
    2.6.18-88.el5
    Average Half load -j 3 Run (std deviation):
    Elapsed Time 135 (2,34521)
    User Time 342,6 (5,77062)
    System Time 57,8 (1,30384)
    Percent CPU 295,6 (1,67332)
    Context Switches 21652,8 (444,057)
    Sleeps 28450,2 (244,64)
 
    Average Optimal load -j 16 Run (std deviation):
    Elapsed Time 109,8 (1,09545)
    User Time 345,7 (5,05635)
    System Time 58,3 (1,05935)
    Percent CPU 332,7 (39,2119)
    Context Switches 29243,2 (8008,14)
    Sleeps 31455,6 (3175,14)
 
    Average Maximal load -j Run (std deviation):
    Elapsed Time 201,6 (182,945)
    User Time 344,6 (4,40454)
    System Time 59,6667 (4,98091)
    Percent CPU 316,8 (75,1676)
    Context Switches 28538,5 (7524,2)
    Sleeps 36443,6 (19414,3)

  Test 5:
    2.6.18-88.el5
    Average Half load -j 3 Run (std deviation):
    Elapsed Time 132,6 (1,14018)
    User Time 337,4 (0,547723)
    System Time 56,4 (0,547723)
    Percent CPU 295,6 (2,30217)
    Context Switches 20987,2 (107,483)
    Sleeps 28642,8 (114,766)
 
    Average Optimal load -j 16 Run (std deviation):
    Elapsed Time 111,8 (1,09545)
    User Time 344,5 (7,51665)
    System Time 58,1 (1,85292)
    Percent CPU 331 (37,4492)
    Context Switches 28867,8 (8309,84)
    Sleeps 31401,8 (2914,73)
 
    Average Maximal load -j Run (std deviation):
    Elapsed Time 132,6 (46,6455)
    User Time 345,733 (6,9741)
    System Time 58,2 (2,73078)
    Percent CPU 329,667 (49,6137)
    Context Switches 27381,1 (7456,1)
    Sleeps 31218,3 (5701,63)
Comment 21 errata-xmlrpc 2008-05-21 11:03:29 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.