Bug 419291 - Xen cpuspeed supported in RHEL 5.2 -> initscript needs changes
Xen cpuspeed supported in RHEL 5.2 -> initscript needs changes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cpuspeed (Show other bugs)
5.2
All Linux
high Severity high
: ---
: ---
Assigned To: Jarod Wilson
:
Depends On:
Blocks: 251969
  Show dependency treegraph
 
Reported: 2007-12-11 02:06 EST by Rik van Riel
Modified: 2008-05-21 13:33 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHEA-2008-0317
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:33:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for the cpuspeed initscript (1.26 KB, patch)
2007-12-11 02:16 EST, Rik van Riel
no flags Details | Diff

  None (edit)
Description Rik van Riel 2007-12-11 02:06:12 EST
Description of problem:

The current cpuspeed initscript bails out when starting on Xen, because cpuspeed
was not supported in Xen under RHEL 5.0 and 5.1.

For RHEL 5.2, the kernel will support cpu frequency scaling.  Test kernels are
available at http://people.redhat.com/riel/xen-cpufreq/

The cpuspeed initscript has a few hacks to make sure cpuspeed is never
initialized on Xen kernels.  These will have to go for RHEL 5.2

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rik van Riel 2007-12-11 02:16:56 EST
Created attachment 283691 [details]
fix for the cpuspeed initscript

With this change to the cpuspeed initscript, cpu frequency scaling will be
enabled on the Xen kernel, provided the user does not try to use the userspace
governor.

I suspect all of the CPUs where Xen is being used will use one of the kernel
space governors anyway, so this should be enough for RHEL 5.2.

As you can see, the patch is restricted to the initscript and only changes the
Xen behaviour, so it is very low risk.
Comment 3 RHEL Product and Program Management 2007-12-11 02:24:21 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 12 errata-xmlrpc 2008-05-21 13:33:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0317.html

Note You need to log in before you can comment on or make changes to this bug.