Bug 41956 - popt can't reuse result of !#:+
popt can't reuse result of !#:+
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: popt (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-23 07:27 EDT by Artur Frysiak
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-23 08:29:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Artur Frysiak 2001-05-23 07:27:07 EDT
Description of Problem:
popt can't handle CVSed version of rpmpopt.in
problem in line like: 
rpmb    alias --with        --define "_with_!#:+       --with-!#:+"

Steps to Reproduce:
1. put: 
rpm alias --with --define "_with_!#:+ --with-!#:+"
in ~/.popt
2. run:
rpm --with 1 2 --eval '%_with_1'

Actual Results:
--with-2

Expected Results:
--with-1
Comment 1 Jeff Johnson 2001-05-23 08:29:11 EDT
I've verified, no idea what's rotted since I added --with.

popt makes my head hurt sometimes ... :-)
Comment 2 Jeff Johnson 2001-05-29 16:01:11 EDT
Fixed (by retrieving next arg only once) in rpm-4.0.3-0.28.

Note You need to log in before you can comment on or make changes to this bug.