Bug 419571 - Selinux prevents haldaemon to start
Selinux prevents haldaemon to start
Status: CLOSED DUPLICATE of bug 425819
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-11 06:17 EST by antonio montagnani
Modified: 2013-03-05 22:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 17:19:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/usr/sbin/hald (hald_t) "read" to (system_crond_var_lib_t). (2.28 KB, text/plain)
2007-12-11 06:55 EST, Jim Cornette
no flags Details

  None (edit)
Description antonio montagnani 2007-12-11 06:17:49 EST
Description of problem:
Selinux prevents haldaemon to start 

Version-Release number of selected component (if applicable):
selinux-policy-3.2.2-1.fc9

How reproducible:
always is Selinux is Enforcing

Steps to Reproduce:
1.Boot the machine
2.
3.
  
Actual results:
Haldaemon is not started, so I don't see CD writer, USB pens, external disks

Expected results:
Everything should be seen

Additional info:

In Permissive mode everything is o.k
Comment 1 Jim Cornette 2007-12-11 06:55:13 EST
Created attachment 283961 [details]
 /usr/sbin/hald (hald_t) "read" to (system_crond_var_lib_t).

This denial message related to SELinux is seen in the troubleshooter browser.
SELinux is preventing /usr/sbin/hald (hald_t) "read" to
(system_crond_var_lib_t).
Comment 2 Jim Cornette 2007-12-11 06:57:59 EST
Once hal is started, using enforcing mode does not seem to produce errors.
Permissive mode is needed to start the daemon initially.
Comment 3 Daniel Walsh 2007-12-12 10:39:25 EST
This is actually a PolicyKit bug, which should install this file in 

/var/lib/PolicyKit-public

selinux-policy in rawhide allows hal to look there for the file.
Comment 4 Jeremy Katz 2007-12-20 17:19:36 EST

*** This bug has been marked as a duplicate of 425819 ***

Note You need to log in before you can comment on or make changes to this bug.