Bug 41971 - procmail not called as LDA from sendmail
Summary: procmail not called as LDA from sendmail
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-23 13:52 UTC by Tethys
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-06 15:26:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tethys 2001-05-23 13:52:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.4 i686; en-US; rv:0.9)
Gecko/20010505

Description of problem:
Under Red Hat 4.x, 5.x and 6.x, sendmail automatically used
procmail as an LDA, and ~/.procmail was consulted for all
locally delivered mail. After upgrading my box to 7.1, this
no longer appears the be the case. Note that my home directory
is NFS mounted from another machine, so I can guarantee that
my .procmailrc didn't change when upgrading.

How reproducible:
Always

Steps to Reproduce:
1.Create a .procmailrc to do something other than deliver to $MAIL
2.Send yourself some mail
3.Watch it get delivered to $MAIL
	

Actual Results:  Mail gets delivered to /var/spool/mail/tet, rather than being
loaded into one of my mh folders using rcvstore called from
~/.procmailrc

Additional info:

The procmail recipes definitely work -- I've been using them
for years under previous versions of RHL.

Comment 1 Trond Eivind Glomsrxd 2001-05-23 14:13:46 UTC
That would be a sendmail issue.

Comment 2 Florian La Roche 2001-07-06 07:57:45 UTC
procmail is used for local delivery, so you must have some other
problems on your host.

Florian La Roche


Comment 3 Tethys 2001-07-06 15:26:04 UTC
This is *NOT* resolved. It is 100% reproducible on an out of
the box RH7.1 install. I get the same behaviour on 3 separate
boxes. If there are problems on the host, it is because they
exist in the default install.

Comment 4 Florian La Roche 2001-08-06 10:38:25 UTC
Please check your sendmail.cf for the "Mlocal" mailer and also your permisssions
on your email config files, since sendmail as well as procmail have more
security checks added.

Default configuration is ok, this must have something todo with your
local setup. If not, please give more information.

Thanks for your report,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.