Bug 419891 - No signal with default mode.
No signal with default mode.
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-11 10:39 EST by Jan ONDREJ
Modified: 2008-05-10 01:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-10 01:38:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
xrandr --verbose (5.95 KB, application/octet-stream)
2007-12-11 10:39 EST, Jan ONDREJ
no flags Details
Xorg.log (50.75 KB, text/plain)
2007-12-11 10:40 EST, Jan ONDREJ
no flags Details
xorg.conf (1.49 KB, application/octet-stream)
2007-12-11 10:43 EST, Jan ONDREJ
no flags Details
xorg.conf (611 bytes, text/plain)
2007-12-12 00:53 EST, Jan ONDREJ
no flags Details

  None (edit)
Description Jan ONDREJ 2007-12-11 10:39:40 EST
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible: Always

Steps to Reproduce:
1. configure monitor automatically or set mode 1920x1280
2. start X server

Actual results:
Blank screen, after few seconds my monitor displays "No signal".

Expected results:
You know. :)

Additional info:
My monitor is not properly detected. I am unable to say to X server, that this mode:
Modeline "1920x1200"x59.9  193.25  1920 2056 2256 2592  1200
  1203 1209 1245 -hsync +vsync (74.6 kHz)
is wrong. Even if I have in configuration statically configured horizsync:
  HorizSync    31.5 - 74.5
this mode is selected. You can see, that this modeline is out of defined sync.
I am attaching my output from Xorg and xrand --verbose output.
I am able to set proper mode with this commend:
  xrandr --output DVI-0 --mode 0x51
Mode 0x51 at 74 kHz works well, but mode 0x50 (which is still autoselected) does
not work.
I don't know, how to tell to X server to ignore this bad mode.

An beginner user is unable to use this mode and it is hard to me too, because I
need to type this commend after logon and my monitor is off.
Comment 1 Jan ONDREJ 2007-12-11 10:39:40 EST
Created attachment 284221 [details]
xrandr --verbose
Comment 2 Jan ONDREJ 2007-12-11 10:40:52 EST
Created attachment 284231 [details]
Comment 3 Jan ONDREJ 2007-12-11 10:43:28 EST
Created attachment 284241 [details]
Comment 4 Jan ONDREJ 2007-12-12 00:53:49 EST
Created attachment 285091 [details]

Previous xorg.conf has been my test, where the problematic mode has been
Comment 5 Jan ONDREJ 2008-02-27 01:58:05 EST
Still not working:

Can I somehow help you?
Comment 6 Matěj Cepl 2008-02-27 02:08:37 EST
Does vesa driver work? (so that at least you would have working computer :-))
Comment 7 Jan ONDREJ 2008-02-27 02:36:22 EST
I can try VESA driver evening, if required, but:

- proprietary fglrx driver works well
- default driver from Fedora works too, but I have to set 60 Hz mode manually
after each login (which is not trivial, because my monitor is OFF)

I think my computer works perfectly. DDC does not send this 59.9 Hz mode to ATI
card. I don't know, where this bad mode rises.

Current solution is to use proprietary driver, but I don't like it and want to
go back to open source driver.
Comment 8 Matěj Cepl 2008-02-27 06:35:46 EST
that xrandr command could be probably added to ~/.xinitrc (see xinit(1) for more).
Comment 9 Jan ONDREJ 2008-02-27 06:46:41 EST
Probally. :-)

But it's a wrong solution for beginners, which have no signal after installation
of Fedora. May be it's a reason, why this bug has been marked as F9Target blocker.

Next proble is, tha I don't know, if it can't damage my monitor. Setting an
unsupported mode and then setting it back to an supported is not a good solution.

And last problem. GNOME's background is not properly set, when changing these
modes with xrandr. But it is another bug. Works well if this bug will be fixed.
Comment 10 Matěj Cepl 2008-02-27 17:46:43 EST
Jan, I am not saying that this is the solution for this problem. Just as a
helpful bugmaster trying to make your life with broken Fedora slightly less painful.
Comment 11 Dave Airlie 2008-04-03 20:18:33 EDT
I've just checked a fix into the upstream server. it'll take a while to come
back downstream, but it definitely should be in F9 final.

maybe if we do another F8 server release I can fix it there.
Comment 12 Dave Airlie 2008-04-09 00:15:06 EDT
Should be fixed for F9 so removing blocker. it would be nice to have confirmation.
Comment 13 Jan ONDREJ 2008-04-09 01:01:17 EDT
I can't install F9 on my machine before it will be marked as stable.

Is it possible to install a package from F9 to F8 to test this?
Or can I test this new update elsewhere on F8?
Comment 14 Dave Airlie 2008-04-09 01:06:52 EDT
no its F9 only testable as it would require bringing in nearly all of F9, in
theory I could add the quirk to f8 but I haven't time at the moment.. you'll
just have to hope I fixed it correctly

Comment 16 Jan ONDREJ 2008-05-10 01:28:21 EDT
My old computer is completely down (requires to press F1 on broken PS/2 port :-).

On my new machine opensource graphics drivers are not working and with
proprietary driver this bug does not occur.

I can't check this anymore, so if you think, it is fixed in F9, you can close
this bug.
Comment 17 Dave Airlie 2008-05-10 01:38:50 EDT
I'll close it as I think its fixed.

Note You need to log in before you can comment on or make changes to this bug.