Bug 41993 - Mozilla does not recognize plugins
Mozilla does not recognize plugins
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-23 11:35 EDT by Bob Miller
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-05 09:49:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Miller 2001-05-23 11:35:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
After loading plugins like Java and restarting Mozilla, Mozilla still only
recognizes the default plugin. Have tried storing plugins both globally
(/usr/lib/mozilla/plugins) and per user. Did NOT have this problem with RH
7.0.

Netscape 4.77 continues to work fine.

How reproducible:
Always

Steps to Reproduce:
1.Start Mozilla	
2.Go to a page that requires a plugin
3.Download plugin, receive, for example "Java plugin successful"
4. Restart Mozilla
5. Mozilla load only the default plugin
	

Additional info:
Comment 1 James Cook 2001-06-01 11:34:16 EDT
I had the same problem.  I'm using the mozilla-0.9 rpms and the jdk-1.3.1 rpm
from sun.  The fix that worked for me was to make the following symlink

ln -s /usr/X11R6/lib/libXt.so.6 /usr/X11R6/lib/libXt.so

After that, mozilla picked up the java and flash plugins (flash seems to depend
on the java plugin because of the .class file I guess.)
Comment 2 James Cook 2001-06-01 11:37:34 EDT
Oh, you do have to run ldconfig for the change to take effect.  :)
Comment 3 Bob Miller 2001-06-05 09:49:55 EDT
Did as stated above. Java seems to work fine. However, any web page that uses
Flash causes the program to crash (e.g., weather.com).

Java 1.3.0_01
Shockware 5.0r47
KDE 2.1.1
Comment 4 Christopher Blizzard 2001-06-09 18:12:14 EDT
This should be fixed in 0.9.1 since we load the Xt libraries now.  Should be in
rawhide shortly.

Note You need to log in before you can comment on or make changes to this bug.