Bug 41995 - rpm seg faults when installing files with a non existant username
Summary: rpm seg faults when installing files with a non existant username
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-23 16:27 UTC by Andrew Howell
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-23 16:43:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RSA ACE/Agent for Linux rpm (563.38 KB, application/octet-stream)
2001-05-23 16:40 UTC, Andrew Howell
no flags Details

Description Andrew Howell 2001-05-23 16:27:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.4 i686)

Description of problem:
I have a rpm I built myself and I forgot to add %defattr(-,root,root) to
the %files section of
the spec file so when it built the files they inherited my uid and gid.
With the RH 6.2 rpm binary it
installs these files fine. With RH 7.1's rpm it seg faults trying to
install when the user doesn't exist. If I install the rpm from a kickstart
postinstall script. If I do it from the command line after
the box has built is just displays a warning that the user doesn't exist.

How reproducible:
Always

Steps to Reproduce:
1. rpm -i http://blah/package from inside a kickstart post install script
2.
3.
	

Actual Results:  rpm seg faults

Expected Results:  It should install with a warning

Additional info:

Comment 1 Jeff Johnson 2001-05-23 16:32:50 UTC
A pointer to your binary package, please, so's I can try to reproduce
the segfault. I suspect that your segfault may actually be due to other
causes: Have you been using the Ximian installer? If so, then please
send me a pointer to a tarball of your database
	cd /var/lib
	tar czvf /tmp/rpmdb.tar.gz rpm
and I'll tell you what to do.

Comment 2 Andrew Howell 2001-05-23 16:40:39 UTC
Created attachment 19410 [details]
RSA ACE/Agent for Linux rpm

Comment 3 Andrew Howell 2001-05-23 16:43:46 UTC
Okay I just attached the rpm in question. No I haven't used the ximian
installer. The box doesn't have X
even installed on it. It's a fresh RH 7.1 box with not much installed built
using kickstart.

I've worked around the bug by specificing the default attributes in the spec
file (which I should have done
before), but rpm shouldn't crash still :)


Comment 4 Jeff Johnson 2001-05-23 17:57:24 UTC
rpm-4.0.3 does not segfault when installing/erasing your package.

Comment 5 Andrew Howell 2001-05-24 10:04:42 UTC
So when is 4.0.3 going to be included in RH 7.1 updates?


Note You need to log in before you can comment on or make changes to this bug.