Bug 420031 - hp6510b kernel panic when lid closed
hp6510b kernel panic when lid closed
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-11 11:36 EST by vladimir benes
Modified: 2009-01-09 00:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:29:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kernel panic screen picz (7.02 MB, application/x-bzip)
2007-12-19 06:09 EST, vladimir benes
no flags Details
whole error message pictures //smaller font (5.68 MB, application/x-bzip)
2007-12-30 08:56 EST, vladimir benes
no flags Details

  None (edit)
Description vladimir benes 2007-12-11 11:36:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); cs-CZ; rv:1.8.1.10) Gecko/20071128 Fedora/2.0.0.10-2.fc8 Firefox/2.0.0.10

Description of problem:
when I close my laptop lid when X server is up.. computer crashes.. Thats also in GDM.. and also after booting my kernel in scripts startup section. I ve booted without rhgb and it is the same (the little difference is that i have to press it more times and faster than in X). 
Ive tried development kernel (2.6.24-0.79.rc4.git5.fc9) and it is the same as in my stable one (2.6.23.8-63.fc8).. so i tried CentOS (5.1) which is based on your RHEL with kernel 2.6.18-53 and thats working fine no lockups when starting neither in X..
The message written out to console looks like this:

this part is almost every time different:
Process Swapper (PID:0,ThredINFO ffff81003f24e000,task ffff81003f24c000,stack: ffff81003f3f7968 ffff81003f24c0000 and so on...

I have also seen:
process MultiPath.Stati(PID:1598,threadinfo....... and so on)

I think this depends on time when it is done..

the bottom is the same all the time
Call trace: Bad Rip Value
RIP [<000000000000000000 I dont know how much of zeroes :)00>]
RSP  <0000000000000000000 the same as above>
CRZ: ffffe200016b0540
Kernel Panic - Not Syncing: Attempted to kill idle task


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.Just pushing the lid button once in X or several times in text mode
2.
3.

Actual Results:


Expected Results:


Additional info:
I can suspend my notebook from X and then close the lid. It is new bug because of that centOS with older kernel. I can try to install older kernel and I will see.. I will post a message later on. 
THX
Comment 1 vladimir benes 2007-12-11 12:13:20 EST
I have forgotten my machine specs:
http://www.smolts.org/show?UUID=1b59afc5-20b9-4dfc-aaaf-ddb795100a6b
Comment 2 Chuck Ebbert 2007-12-18 14:05:50 EST
We need to see the entire message when it crashes. Try booting in 50-line mode
9add kernel option 'vga=1') and taking a digital picture of the screen and
attaching that.
Comment 3 vladimir benes 2007-12-19 05:02:14 EST
i did as you had told me before but 50 line mode is only while kernel is
booting. In the scripts part there is again normal font.. I have also tried the
XEN kernel .. and.. voila.. everything is ok
pictures of my faults are included..
XEN-kernel version is 2.6.21-2952.fc8xen
i'll try to switch font in script-faze of boot and attach more pictures 
Comment 4 vladimir benes 2007-12-19 06:10:00 EST
Created attachment 290004 [details]
kernel panic screen picz
Comment 5 vladimir benes 2007-12-30 08:56:32 EST
Created attachment 290549 [details]
whole error message pictures //smaller font
Comment 6 Matti Hyötyniemi 2008-07-15 06:10:31 EDT
I am having a similar problem with HP Compaq 6710b. (fc8-64, all kernels).
However, my computer doesn't always crash, in some cases only the terminal
keyboard seem to be disfunctional after the lid is reopened, (USB-) mouse and
terminal screen continue to function  as  well as remote logging with or without
X. This seem to happen most times when user is logged in and the screensaver is
active when the lid is being closed. 

In many cases, however, the computer halts altogether. Something wrong with the
keyboard (including lid sensor) management?
Comment 7 Bug Zapper 2008-11-26 03:57:32 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2009-01-09 00:29:15 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.