Bug 4201 - Can't remove a redhat package
Summary: Can't remove a redhat package
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-26 18:20 UTC by bmann
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-14 18:09:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bmann 1999-07-26 18:20:36 UTC
I created a package with a hyphen in the release field
(package: pbs-mom version: 2.1 release: 15-RH5).  The
resulting package is called pbs-mom-2.1-15-RH5.  It
installed correctly, but when I try and remove the package,
RPM tells me the package is not installed.  I checked with
rpm -q and it says the package does exist.  I upgraded to
rpm 3.0.2-6 and it didn't fix the problem.

Comment 1 Jeff Johnson 1999-07-26 21:25:59 UTC
Try specifying rpm -e --allmatches your_package_here to uninstall
package. You also need to do "rpm --rebuilddb" after upgrading
to rpm-3.0.x.

Comment 2 bmann 1999-07-26 21:54:59 UTC
I rebuilt the database and tried rpm -e <package name> and rpm -e
-allmatches <package name> and still got the same result.
I can provide the package for testing if needed.

Comment 3 Elliot Lee 2000-02-03 17:16:59 UTC
Erase it by package name only (e.g. 'pbs-mom'), not by the full package
name-version-release combo.

Comment 4 Jeff Johnson 2000-12-30 19:14:04 UTC
This problem appears long since resolved.


Note You need to log in before you can comment on or make changes to this bug.