Bug 4202 - New kernel causes Vmware 1.03 to segfault
New kernel causes Vmware 1.03 to segfault
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-26 15:00 EDT by George Karabin
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-28 03:03:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description George Karabin 1999-07-26 15:00:36 EDT
I had been running kernel 2.2.5-22 on my RH 6.0 based
computer. Vmware 1.03 works with that kernel. Something has
changed afer installing kernel 2.2.10-1 that causes vmware
to segfault after I try to power on the virtual OS.

I can switch back to the 2.2.5-22 kernel, and get vmware to
work.

Vmware is one of the programs that lets coders in the
corporate world run linux on our desktops, since we are tied
to MS-Office. This is almost certainly a problem with
vmware, not with redhat, but if you are able to assist them,
that would be cool.


http://www.vmware.com
Comment 1 George Karabin 1999-07-27 16:04:59 EDT
I received some feedback from Kenon Owens of Vmware. They are
addressing this in future releases, and have a fix for anyone with new
kernels. I've booted my vmware installation, so this can be resolved,
I guess.

From Kenon Owens:
-------------------------------------------
First of all, the support website should be back up now.

Secondly, about the Segmentation Fault, it is most likely due to the
fact
that the New Mandrake Kernel
is compiled for Big Mem.  Here are the steps necessary to resolve this
issue:

Troubleshooting Steps:  Find out if they built in "big memory" or
Large
Kernel Support (Support for Kernel's
over 1GB addressable memory space.)  To find this out look in the file
/usr/include/adm/page.h   If the
__PAGE_OFFSET variable exists and has a value of 0x80000000 then the
kernel
is set up for Large Kernel
Support and the solution is detailed below.

Solution:  Perform the following steps to get the 1.0.x versions of
VMware to
handle Large Kernel Support:

A)  Uninstall VMware for Linux (using ./install.pl)

1)  In the vmware-distrib directory (as root) untar the
driver-only.tar file:

                        tar xvf driver-only.tar

2)  Modify vmware-distrib/driver-only/common/hostif.h by replacing
0xc0000000
with 0x80000000

3)  Recreate the tar file with the following command:
                        tar cvf driver-only.tar driver-only/*

4)  Reinstall VMware  (./install.pl)

Background:  Normal Installs of LINUX have 4GB of addressable memory.
The
first 3 GB are used
for USER applications, and the last 1 GB is used for Kernel Apps.
This
equates to the Kernel
Address Space starting at 0xc0000000.  With Large Kernel Support
turned on,
the kernel is now
able to address the last 2GB of space instead of just the one.  This
equates
to the Kernel Address
Space starting at 0x8000000.

VMware 1.1 will not have this problem.  It is also addressed in the
Experimental Builds out now.

We have had a few customers reporting this problem to support, and
this has
resolved their issues.

Good Luck,

Kenon
VMware Customer Service


George J. Karabin wrote:

> guest wrote:
>
> > I just finished installing the updated kernel .rpms (including
source
> > and headers), running lilo, re-running the install.pl script which
> > successfully built the vmmon and vmnet modules (which are
currently
> > loaded), and rebooting.
> >
> > Now, vmware (1.0.3) gives  a segmentation fault on powerup.
> >
> > Do I have a version incompatibility problem, perhaps?  Any
> > suggestions?
>
> I've got a post under a different thread "Problems with 2.2.10
kernel
> under RedHat 6.0?" where I'm seeing the same thing. I've filed a
bugtraq
> report (#4202) against Redhat's rawhide kernel release. I would have
> filled in a vmware report, but their server wasn't working when I
tried.
>
Comment 2 Cristian Gafton 1999-07-28 03:03:59 EDT
vmware modules need to be recompiled against new headers (and possily
patched)

Note You need to log in before you can comment on or make changes to this bug.