Bug 420281 - Cannot find kickstart file during unattended installation
Cannot find kickstart file during unattended installation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-11 13:35 EST by Arturo Alejandro Hoffstadt Urrutia
Modified: 2008-04-07 13:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 15:11:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arturo Alejandro Hoffstadt Urrutia 2007-12-11 13:35:03 EST
Description of problem:
Using the first DVD image of Fedora 8, we tried with an actualized kickstart
file (we use kickstart in our laboratory since redhat 7.3), to make an
unattented installation of a computer.

But every attempts results in a failure, because anaconda tries to fetch from
the server a file that doesn't exists. The logs shows that it tries to fetch the
file for the same IP that the kickstart-files server has, instead of the file
that has the same IP that the DHCP server assings statically to the PC that is
beign kickstarted.

If we specify manually the kickstart file, anaconda fetches the correct file,
and the kickstart process continues normally.

For example:
The IP from the NFS server is: 204.87.169.3
The IP from the PC is: 204.87.169.67 (DHCPACK with this IP)

Anaconda tries this file location:
nfs://204.87.169.3:/kickstart/204.87.169.3-kickstart
when it should try to download the file:
nfs://204.87.169.3:/kickstart/204.87.169.67-kickstart

How reproducible:
Every Time


Steps to Reproduce:
1. Create an DHCP+NFS configuration for kickstart
2. Host the kickstart files in the NFS server (The NFS server has no kickstart
files)
3. Use the F8 DVD image to kickstart a PC (in the boot line from the DVD image:
linux ks text)
  
Actual results:
An error:
"Error downloading kickstart file"
"Unable to download the kickstart file...."

Expected results:
A normal unattented installlation.

Additional info:
Comment 1 Chris Lumens 2007-12-11 15:11:07 EST
This will be fixed in the next build of anaconda.  Thanks for the detailed bug
report.
Comment 2 Edgar Hoch 2008-02-07 20:27:45 EST
The bug still exists in Fedora 8 Re-Spin 20080204.

I filed a bug report there:
http://bugs.fedoraunity.org/spin-bugs/11/

As we use kickstart and dhcp and nfs for all our installations,
Fedora 8 is still unuseable for us.

Why where there no new boot image created without that bug?

I am wondering if nobody ist using kickstart with dhcp and nfs in this way?
Comment 3 Jeroen van Meeuwen 2008-02-19 19:33:57 EST
anaconda doesn't get updates in between releases. This has only been fixed in
rawhide and thus isn't solved in the Fedora Unity Re-Spins. I could dig up the
commit that Chris made and see if I can backport it.
Comment 4 Eric Doutreleau 2008-03-04 06:25:14 EST
i have exactly the same problem
i can't move to f8 right now and the eol of f7 is not so far away :(
Comment 5 Edgar Hoch 2008-03-18 17:01:02 EDT
Hello Jeroen,

I searched the source and it think I found the patch:

http://git.fedorahosted.org/git/anaconda.git?p=anaconda.git;a=commitdiff_plain;h=b748e5208808a44799526329d9efb3086b7b76d3

Is it possible that you can apply it to anaconda-11.3.0.50-6
and include then new package in the next F8 respin?
I tried to build anaconda-11.3.0.50-6 with the patch applied and it
and has build the rpms without an error.
But I can't test the result - I'm just not sure how to build a respin
just like the release re-spins but with only the patch applied.
(I read some documents about revisor but I had not found the exactconfiguration
files for the release f8 respins (and updates-f8-yumloop.img, for example).)

Thanks in advance!
Comment 6 Edgar Hoch 2008-04-07 13:02:25 EDT
I have tested Fedora 8 Respin 20080331 and it works!
This bug is fixed and resolved in Fedora 8 Respin 20080331, many thanks!!!

Note You need to log in before you can comment on or make changes to this bug.