Bug 42030 - SPM needs APM completely absent in compiled kernel, on some motherboards.
SPM needs APM completely absent in compiled kernel, on some motherboards.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-23 15:22 EDT by Erich Boleyn
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 08:54:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erich Boleyn 2001-05-23 15:22:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.4-xfs i686; en-US; 0.7)
Gecko/20010316

Description of problem:
On some SMP motherboards (ABit BP6 is the one I have), when using an SMP
kernel, Power Management apparently needs to be disabled in the kernel
config file.  I am still doing some other testing to verify that this is
the only solution, but it is the first thing that has worked so far.
Symptoms include:
  --  Console doesn't work after finishing boot
  --  Random failure of network or disk devices w/large FTP transfers.

How reproducible:
Always

Steps to Reproduce:
1.Boot standard RH 7.1 SMP kernel on ABit BP6 w/2 processors.
2.FTP very large file over network to this machine (my test file was ~2GB,
8.5GB w/XFS kernel which had identical problem to stock RH 7.1 SMP kernel).
3.notice network or disk hang at some point in transfer.  For the 8.5GB
file (which is too big for ext2fs), I would always get a failure before the
end of the file.  For ext2fs file ~2GB, I might need 2-3 transfers to get
it to hang the network or disk.  Occasionally it would lock up the whole
machine.

Also, I noticed that the text console, after the boot sequence finishes and
it's switched to multiple console mode, would not respond to keyboard to
mouse input.  This would go away by starting X in some fashion.  Then
keyboard and mouse input, even on the text consoles, works fine.  I thought
this was a 2.4.X kernel problem til I got rid of APM and it worked fine
afterward.


	

Actual Results:  Network or disk hung.

Console unresponsive to keyboard or mouse once multi-console mode after
boot sequence finishes turns on (i.e. the gettys are active).  Again, this
could be worked around by starting X in some way, but completely removing
APM from the kernel config fixed it completely.


Additional info:

I just think this board has a buggy APM BIOS anyway (as the console problem
was present on the UP kernel w/APM enabled), but in general APM and SMP
don't mix too well.  It would be better to completely remove APM from the
default SPM config file.
Comment 1 Arjan van de Ven 2001-05-23 15:35:43 EDT
APM is disabled at runtime by the kernel, but enabling it allows you 
to poweroff the machine at shutdown.

Re the BP6. I have one at home, and it works well with our default kernel.
However, there has been a batch of BP6 boards that are "different" (some call it
"less stable") and require you to pass "noapic" to the kernel on the lilo
prompt.
Could you try this ?

Note You need to log in before you can comment on or make changes to this bug.