Bug 42034 - perl's perltoc manpage is useless
Summary: perl's perltoc manpage is useless
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-23 20:18 UTC by Mike A. Harris
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-06 21:25:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike A. Harris 2001-05-23 20:18:34 UTC
Description of Problem:  The perltoc manpage is totally garbled.


How Reproducible:  Only on days of the week ending in y


Steps to Reproduce:
1. man perltoc

Actual Results:  Total garbage is displayed by man


Expected Results:  The perltoc manpage in easily readable format like
other manpages


Additional Information:  This wizard thing is a bit overboard for
some bugs (ie this one), but nonetheless has a humorous aspect.  ;o)

Comment 1 David Lawrence 2001-05-23 20:31:17 UTC
This seems to format fine when using the perldoc command instead of man. 

Example:

perldoc perltoc
man perltoc

These offer two different formats. Seems like man is not registering properly
certain characters such as new lines, etc.

Comment 2 Chip Turner 2001-12-19 08:31:28 UTC
this is possibly a bug in pod2man.  a more recent version ships with perl 5.6.1,
which is now in rawhide.  both perldoc and man to view perltoc works for me with
this rpm


Note You need to log in before you can comment on or make changes to this bug.