Bug 420341 - Installer fails immediately after skipping cd check.
Installer fails immediately after skipping cd check.
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.1
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-11 14:05 EST by Jacob Certain
Modified: 2011-06-29 10:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-21 13:19:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacob Certain 2007-12-11 14:05:57 EST
Description of problem:
Installer fails immediately after skipping cd check. Error is:

Running anaconda, the Red Hat Enterprise Linux Server system installer - please
wait...
Probing for video card: ATI Technologies Inc Rage XL
Attempting to start native X server
Waiting for X server to start...log located in /tmp/ramfs/X.log
1...2...3...4...5... X server started successfully.
Starting graphical installation...
Traceback (most recent call last):
     File "/usr/bin/anaconda", line 900, in ?
          iutil.makeDriveDeviceNodes()
     File "/usr/lib/anaconda/iutil.py", line 264, in makeDriveDeviceNodes
          isys.makeDevInode(device, "/dev/%s" % (device,))
     File "/usr/lib/anaconda/isys.py", line 422, in makeDevInode
          _isys.mkdevinode(name, fn)
SystemError: (2, 'No such file or directory')
install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
          /mnt/runtime done
          disabling /dev/loop0
          /proc/bus/usb done
          /proc done
          /devpts done
          /sys done
          /tmp/ramfs done
          /mnt/source done
          /selinux done
you may safely reboot your system

I get the same error when choosing text install (sans the x server stuff, of
course).


Version-Release number of selected component (if applicable):

n/a

How reproducible:

Every time on this machine (HP Proliant ML350). Install has worked fine on other
servers, including an HP Proliant DL380.

Steps to Reproduce:
1. Boot from RHEL 5.1 disc (64 or 32 -bit). Disc known to work on other
computers, before and after this attempt, passes checksums.
2. Skip cd check.
3. Error.
  
Actual results:

Installer fails.

Expected results:

Installer installs.

Additional info:

Installer runs fine on an HP Proliant DL380
Comment 1 Jacob Certain 2007-12-20 14:33:21 EST
RHEL 5.0 64bit installs without a hitch on the exact same configuration.
Comment 2 rl03 2007-12-23 11:47:56 EST
Same issue here, worked around by disabling the tape drive.
Comment 3 Jacob Certain 2007-12-27 13:06:09 EST
For me, installer continues to fail even after removing tape drives.
Comment 4 Chris Lumens 2008-06-21 13:19:34 EDT
This will be fixed in the next major release of anaconda in RHEL.

Note You need to log in before you can comment on or make changes to this bug.