Bug 420361 - RHEL5 will not install on Sun Ultra 40
RHEL5 will not install on Sun Ultra 40
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: David Milburn
Red Hat Kernel QE team
Depends On:
  Show dependency treegraph
Reported: 2007-12-11 14:23 EST by Ray Van Dolson
Modified: 2013-10-30 18:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-10-30 18:22:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg output (16.00 KB, text/plain)
2007-12-11 14:23 EST, Ray Van Dolson
no flags Details
lspci output (2.41 KB, text/plain)
2007-12-11 14:23 EST, Ray Van Dolson
no flags Details
/proc/scsi/scsi output (176 bytes, text/plain)
2007-12-11 14:24 EST, Ray Van Dolson
no flags Details

  None (edit)
Description Ray Van Dolson 2007-12-11 14:23:05 EST
Description of problem: We are attempting to install RHEL Server 5.1 x86_64 on a
Sun Ultra 40.  The Sun is running Dual Opterons, has 16GB's of memory, dual
Quadro NVidia cards and a 250GB SATA hard drive.  The chipset appears to be
nVidia's CK804.

The installation works fine using defaults up until the point where anaconda
attempts to format the first LVM.  It appears to make it through the creation of
all the inodes, but never quite completes.  Eventually an error pops up in the GUI:

"An error occurred trying to format VolGroup00/LogVol00.  The problem is
serious, and the install cannot continue."

Output from dmesg at this time shows many timeouts waiting for ADMA IDLE (will
attach output).

After rebooting, the drive no longer is visible to the OS and doesn't show up in
BIOS either.  We have to reseat the drive to get it to show up again.

Solaris 10 installs perfectly on this machine.

We have tried the following:

 - Moved disk to different SATA slots
 - Used a different SATA drive (known working)
 - Upgraded machine BIOS to 1.6
 - Tried booting with noacpi noapic and acpi=noirq

None of the above resolves our issue.  I would normally think this is the result
of bad hardware, but as Solaris 10 installs perfectly on the machine I am
thinking it may be a problem with the sata_nv driver.

Attached are the output of dmesg, lspci and the /proc/scsi/scsi file.

I will also open a support request with RH support for this issue and reference
this bz.

Version-Release number of selected component (if applicable): Kernel included
with stock 5.1 Server release

How reproducible: Always
Comment 1 Ray Van Dolson 2007-12-11 14:23:05 EST
Created attachment 284501 [details]
dmesg output
Comment 2 Ray Van Dolson 2007-12-11 14:23:46 EST
Created attachment 284511 [details]
lspci output
Comment 3 Ray Van Dolson 2007-12-11 14:24:09 EST
Created attachment 284521 [details]
/proc/scsi/scsi output
Comment 4 Ray Van Dolson 2007-12-11 14:33:55 EST
Created SR #1790490 with RH support for this.
Comment 5 Ray Van Dolson 2007-12-12 12:39:37 EST
Update on this.  Per RH support we tried the installation _without_ LVM and so
far it is proceeding just fine.

Fails every time with the above symptoms however with LVM enabled.
Comment 6 Ray Van Dolson 2007-12-13 14:22:10 EST
Also, when creating the partitions and LVM by hand (from command prompt while
still at the welcome screen) also lets the install complete just fine.  We are
able to create a custom layout with the LVM defined by hand and anaconda appears
to have no troubles formatting.

So it seems only when we leave the LVM and partition creation up to the GUI do
we have issues.

Am not sure if the lvm commands I used are the same as the ones anaconda uses:

# lvm pvcreate /dev/sda2
# lvm vgcreate VolGroup00 /dev/sda2 -s 32M
# lvm lvcreate -L 2G -n LogVol01 VolGroup00
# lvm lvcreate -l 100%FREE -n LogVol00 VolGroup00
Comment 7 Ray Van Dolson 2007-12-28 11:28:58 EST
Update on this.

The manual installation above was using the a non-Sun hard drive (120GB's). 
When we reverted to the 250GB drive provided by Sun the manual setup of LVM and
partitions did not work.

It resulted in mkfs.ext3 hanging and SCSI errors once again showing up in dmesg.
 The drive would be "disabled" and not show up on the system again until it was

We found the solution to the problem to be disabling LBA on the drive during
installation.  With LBA disabled, the installation works perfectly -- even in
fully automated mode from anaconda.

However, after the installation the system does not boot and can't find Grub. 
The solution at this point is to _reenable_ LBA.  Then the system boots fine.
Comment 10 John Feeney 2013-10-30 18:22:00 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being
addressed in Red Hat Enterprise Linux 5, and therefore is being closed.
If this bug is critical to production systems, please contact your Red
Hat support representative and provide a sufficient business justification
in order to re-open it.

Note You need to log in before you can comment on or make changes to this bug.