Bug 42038 - Installer fails to load X and crashes in expert install mode on a Compaq Armada E500
Summary: Installer fails to load X and crashes in expert install mode on a Compaq Arma...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-23 22:20 UTC by Johnray Fuller
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-06-10 14:46:59 UTC


Attachments (Terms of Use)

Description Johnray Fuller 2001-05-23 22:20:29 UTC
Description of Problem:

I had the customer type:

linux expert

At the installer boot prompt. When anaconda loaded and attempted to startx,
if failed and the system immediately went down for reboot.

How Reproducible:

He tried it twice.

Steps to Reproduce:
1. boot installer with linux expert 
2. anaconda loads
3. X fails to load and the system goes down for reboot

Actual Results:

Installer crashes...

Expected Results:

wanted to install...

Additional Information:
	
I am Cc:ing the customer so he can be more specific about his hardware and
help you trouble shoot.

He has a Compaq Armada E500.

Comment 1 Brent Fox 2001-05-25 03:58:02 UTC
What kind of video card does this machine have?

Comment 2 Chris Kelly 2001-05-25 17:35:52 UTC
it is an ATI Rage p/m Mobility AGP 2x video card


Comment 3 Brent Fox 2001-05-31 18:13:01 UTC
Can you install using text mode?  I think that there could be something
particular about the screen that is causing the X server to fail.  I know that
the ATI Rage Mobility video chipset should work, since that's what I have on my
Compaq Presario 1700T laptop.  

The installer is designed to fall back to text mode automatically if the X
server crashes for any reason.  However, what apparently happens is that
sometimes the X server crashes in such a way that it crashes the installer,
which prevents us from falling back to text mode.  This appears to be one of
those cases.

Comment 4 Brent Fox 2001-06-10 14:46:55 UTC
Closing due to inactivity. Please reopen if you have more information.


Note You need to log in before you can comment on or make changes to this bug.