Bug 420671 - Error - Package updater Linux 5.0 server
Error - Package updater Linux 5.0 server
Status: CLOSED DUPLICATE of bug 378911
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.0
All Linux
low Severity high
: ---
: ---
Assigned To: Pradeep Kilambi
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-11 17:32 EST by Richard LeBleu
Modified: 2008-08-05 15:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-05 15:47:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard LeBleu 2007-12-11 17:32:43 EST
Description of problem:
Error when trying to update software.

Version-Release number of selected component (if applicable):
Summary: TB471250f2 grabber.py:1200:_do_grab:IOError: [Errno 2] No such file or 
directory: '//var/cache/yum/rhel-x86_64-server-5/headers/krb5-devel-1.6.1-
17.el5.i386.hdr'

How reproducible:
Every time I run Software updater

Steps to Reproduce:
1.Click on applications > system tools > software updater
2.select apply updates
3.
  
Actual results:
The above error.

Expected results:
update software

Additional info:
New install of RHEL 5.0 Server. Just trying to get the first update from RHN.
Rest of error:

Component: Software Updater
Summary: TB471250f2 grabber.py:1200:_do_grab:IOError: [Errno 2] No such file or 
directory: '//var/cache/yum/rhel-x86_64-server-5/headers/krb5-devel-1.6.1-
17.el5.i386.hdr'

Traceback (most recent call last):
  File "/usr/sbin/pup", line 438, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 557, in 
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 322, in 
checkDeps
    self.populateTs(keepold=0)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 201, in 
populateTs
    self.downloadHeader(txmbr.po)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 863, in 
downloadHeader
    cache=repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 602, in getHeader
    cache=cache,
  File "/usr/lib/yum-plugins/rhnplugin.py", line 208, in _getFile
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 277, in _noExceptionWrappingGet
    http_headers=headers,
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 927, in 
urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 845, in 
_retry
    r = apply(func, (opts,) + args, {})
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 915, in 
retryfunc
    fo._do_grab()
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 1200, in 
_do_grab
    else: new_fo = open(self.filename, 'wb')
IOError: [Errno 2] No such file or directory: '//var/cache/yum/rhel-x86_64-
server-5/headers/krb5-devel-1.6.1-17.el5.i386.hdr'

Local variables in innermost frame:
self: <addinfourl at 314878144 whose fp = None>
Comment 1 Nalin Dahyabhai 2007-12-11 17:52:04 EST
This looks like an RHN header of some kind.  Bouncing it over there (and taking
a guess at the component).
Comment 2 Richard LeBleu 2007-12-12 10:34:57 EST
Hi,

I was finally able to load the update through the command line using yum. The 
yum command kept giving me an error on the xen-libs dependcies. I removed the 
xen-lib package and reinstalled it and was able to install all updates through 
yum. However, I still not able to install any updates through the Software 
Updater gui.

Richard LeBleu
Comment 3 James Bowes 2007-12-13 09:19:29 EST
The xen-lib issue was probably because your system is not subscribed to the
virtualization child channel for rhel. 
Comment 4 Richard LeBleu 2007-12-13 09:31:11 EST
Ok, but how do I get pass the errors when using the Software Updater gui?
Comment 5 Richard LeBleu 2007-12-13 11:28:35 EST
I get the following error when running software updater.

Component: Software Updater
Summary: TBd05087db rhnplugin.py:298:_noExceptionWrappingGet:UnboundLocalError: 
local variable 'result' referenced before assignment

Traceback (most recent call last):
  File "/usr/sbin/pup", line 438, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 557, in 
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 322, in 
checkDeps
    self.populateTs(keepold=0)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 201, in 
populateTs
    self.downloadHeader(txmbr.po)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 863, in 
downloadHeader
    cache=repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 602, in getHeader
    cache=cache,
  File "/usr/lib/yum-plugins/rhnplugin.py", line 209, in _getFile
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 298, in _noExceptionWrappingGet
    return result
UnboundLocalError: local variable 'result' referenced before assignment

Local variables in innermost frame:
remote: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-x86_64-server-
5/getPackage/net-snmp-libs-5.3.1-19.el5_1.3.i386.rpm
start: 440
url: None
text: None
self: rhel-x86_64-server-5
cache: True
reget: None
server: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-x86_64-server-5
relative: getPackage/net-snmp-libs-5.3.1-19.el5_1.3.i386.rpm
headers: (('X-RHN-Auth-Expire-Offset', '3600.0'), ('X-RHN-Auth-User-Id', ''), 
('X-RHN-Auth', 'P3O8+6ZhLpmkngAlL1Z7jw=='), ('X-RHN-Auth-Server-
Time', '1197563100.12'), ('X-RHN-Server-Id', 1008716264))
checkfunc: (<bound method PackageUpdater.verifyHeader of 
<__main__.PackageUpdater object at 0x1c2cd410>>, 
(<yum.sqlitesack.YumAvailablePackageSqlite object at 0x216c0bd0>, 1), {})
copy_local: 1
end: 28408
local: //var/cache/yum/rhel-x86_64-server-5/headers/net-snmp-libs-5.3.1-
19.el5_1.3.i386.hdr
Comment 6 Richard LeBleu 2007-12-14 10:33:51 EST
Can anyone please let me know if there is a solution to this problem. I can't 
update through the Software Updater. Is there a package I need to reinstall? 
Does this only only occur on 64bit architectures?

I don't have any problems using Software Updater on a 32bit architecture.

Richard LeBleu 
Comment 8 RHEL Product and Program Management 2008-06-04 18:47:20 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Note You need to log in before you can comment on or make changes to this bug.