Bug 42070 - Promise Ultra66 IDE Controller causes install to hang
Promise Ultra66 IDE Controller causes install to hang
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-05-23 21:25 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-06-08 16:38:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-23 21:25:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Win98; U)

Description of problem:
Installing off the bootable RH7.1 CD, when my Promise Ultra66 (PDC20262) is installed in the computer, the install hangs during
initial hardware detection.

How reproducible:

Steps to Reproduce:
1. Boot off Red Hat 7.1 install CD with Promise Ultra66 card installed in computer with Quantum Fireball Plus KA (18.2 GB) drive in hde 
position (IDE2 master)
2. Choose normal install (hit enter), choose text install, choose expert install- it doesn't seem to matter!


Actual Results:  Install consistently hangs after minimal initial hardware detection.  It does correctly identify the installed hard drives and CD 
drives on ide0 and ide1; it even correctly identifies the Promise Ultra66 (PDC20262) on ide2 and ide3- with the correct memory addresses and 
IRQ, as well as the Quantum Fireball drive installed as master on ide2.  After identifying these components, it gives a full description
of hda (cylinders, heads, sectors) and then hangs.

Expected Results:  Install should not hang.

Additional info:

I can get the install to proceed correctly if I remove the Promise Ultra66 card from its PCI slot.  The install proceeds perfectly onto my hda hard 
drive; I can then re-insert the Promise Ultra66 card and boot into the freshly installed (on hda) OS.  Logging in as root I can then mount the 
/dev/hde hard drive (on the Ultra66 controller) and everything works fine- it just seems to be a problem with the 
boot CD or installation process.
Comment 1 Need Real Name 2001-05-24 23:33:50 EDT
The install also hangs at the same place if I create a boot floppy to start the
install from (and boot
off it)
Comment 2 Brent Fox 2001-05-24 23:47:38 EDT
This is strange, because we have a Promise Ultra66 in one of our test machines
and it works fine...
Comment 3 Need Real Name 2001-05-30 12:11:24 EDT
Hi!! I also am having this problem except I have two hard drives one is Maxtor 
9 2049H2 (1st hard drive c,d in Windows) and Quantum Fireballp KX IDE (2nd hd 
or e, also have Promise Ultra 66 IDE Controller. It detects the hard drives as 
hde and hdf then hangs, and I don't even get to installation screen, also tried 
expert text mode and some problem.  Should I try what you did by taking out the 
controller card??  or should I wait for a fix????
Comment 4 Need Real Name 2001-05-30 13:19:30 EDT
I have a Promise Ultra 100 card on a AZZA 633/AS Motherboard with the VIA 
Chipset.  The Drive was detected correctly identified by the install program as 
hde (The IDE controllers on the motherboard are hda, hdb, hdc, hdd) therefore 
hde is the 1st drive on the promise card.  The install itself went without a 
hitch, but upon bootup the system hung after identifying the controllers on the 
motherboard (correctly.  It never got to the "OK" checks and there were no 
error messages -- it just stopped.

Comment 5 Brent Fox 2001-05-31 13:57:50 EDT
What if you try booting with 'linux ide=nodma'?  Does that help at all?
Comment 6 Need Real Name 2001-05-31 14:14:25 EDT
Tried it, it didn't work.  Still stops after hardware detection.  I was 
thinking of trying to copy cd's to 2nd hard drive in windows partition then use 
expert mode.

Comment 7 Brent Fox 2001-06-04 11:37:05 EDT
swgipson, you can use expert mode without having to try a hard drive install. 
That shouldn't change anything.

starsmann, I would recommend filing a bug against the kernel for the issue that
you are seeing.  If the install completes, but then the kernel hangs on reboot,
then it's a kernel problem.
Comment 8 Need Real Name 2001-06-04 11:44:11 EDT
Question!  When you took out the controller card did you change the BIOS?? Then 
When you put back the Controller card did you reset the BIOS??  I'm thinking of 
trying this and just want to make sure I do it right. I Have the first part of 
my 2nd hard drive partitioned and formatted for Linux so it would be /dev/hdf??

Comment 9 Need Real Name 2001-06-04 23:33:00 EDT
All I did was unplug the IDE cable from the Ultra66 card leading to my hard
drive.  At boot, this caused the Ultra66 card to say "no drives detected-
Ultra66 BIOS not installed", and then I could install 7.1 without a single
hitch.  The Ultra66 card was still in the computer, but there were no hard
drives physically attached to it, so its BIOS was not installed.  I then
proceeded to install onto /dev/hdb (the slave device on ide0, which is handled
by the motherboard).  I suspect if you have any drives attached to your Ultra66
(i.e. hdf) that you will continue to have problems.  But I did not alter my
normal BIOS in any way- just unplugged the IDE cable from the Ultra66 card to my
fifth hard drive (hde).
Comment 10 Need Real Name 2001-06-05 11:37:11 EDT
I was able to install after unplugging the controller card, I followed 
kfrender's instructions, when I went to plug back in the controller card it 
hangs before I can get to ok's,  If I leave the controller card unpluged I have 
no problem booting into Linux.  Let me know if there is a fix in future plans, 
without the controller card I am limited to only 2 hard drives which is ok for 
Comment 11 Need Real Name 2001-06-05 12:38:34 EDT
I didn't alter BIOS either.
Comment 12 Brent Fox 2001-06-11 12:05:17 EDT
This is sounds like a driver problem with the Ultra66 card.  Like I said before,
though, this works in our test machine.
Comment 13 Need Real Name 2001-06-14 09:40:37 EDT
My windows drivers are up to date.  Is there different drivers for linux?? If 
so can you point me in the right direction to find out more?
Sharon the linux newbie
Comment 14 Arjan van de Ven 2001-06-25 13:59:28 EDT
We released a new kernel 2.4.3-12 last friday, with a new Promise IDE driver.
Also, I'm writing a driver for the fasttrak raid, but that isn't 100% stable

Could you please try the 2.4.3-12 kernel and see if that tolerates the
controller ?
Comment 15 Marcus McClary 2001-06-27 00:05:18 EDT
I have the same problem with an onboard Promise Ultra66. On install (7.1-2.4.2
kernel) it hung at hardware detection: 
ide1 at somememoryaddr on someirq
ide2 at somememoryaddr on someirq
it hangs here...

I was able to complete the install with the appended parameter 'ide2=noautotune'

I then upgraded to kernel 2.4.3-12 and it now hangs even with the kernel
parameter appended.

Interestingly, it now lists ide0, ide1,hang instead of ide1, ide2.
Comment 16 Bill Gradwohl 2001-06-29 16:21:34 EDT
Tyan mainboard Tiger 200 S2505 - Dual P-III with a PROMISE Fast Trak 100 
builtin. BIOS V1.02 020801 (The latest available).
Machine has 4 40Gig Maxtor drives on the array controller and 1 80 Gig Maxtor 
on the standard IDE controller.

The machine was using all drives including the RAID array when NT 4.0 or W2K 
was installed. Array was set up as a RAID 1 with 80 Gig on the array. The 
hardware works, and the BIOS settings don't allow for configuring the Promise 
controller in any way. During boot, the controller allows for array creation 
and maintenance.

Install of RH7.1 produces messages ending in
PDC20267 Neither IDE port enabled (BIOS)

Install occurs on the 80Gig with no problems.
Boot of machine shows that the PDC20267 is being detected but the same message 
indicates that the system won't use the array.

Any ideas?
Comment 17 Arjan van de Ven 2001-07-02 04:43:54 EDT
Fasttrak raid is currently not supported because Promise so far has refused
to give information on how to write drivers for the array. I'm writing a
reverse engineered driver but that takes a bit more time...
Comment 18 Bill Gradwohl 2001-07-02 16:13:12 EDT
If you get to the point where you want to test the fasttrak driver on the 
version of their controller that gets imbedded on a main board, let me know. 
Since I've got an SMP setup, I can also run tests for that environment.

Thanks for the update
Bill Gradwohl
Comment 19 Need Real Name 2001-08-26 13:59:25 EDT
For those of you with the Promise Ultra66 problem, there is a way to install 
without having to open your machine.  Boot using the RH install disk.  When 
the "Choose type of install" screen comes up (the first screen asking if you 
want graphic, text, expert installation) press CTRL-ALT-F2 to get to a BASH 
prompt.  At the prompt, type:  cat proc/pci.  Use SHIFT+PAGE UP to scroll up to 
where the information is about the Promise card.  There should be a list of I/O 
that looks something like:  I/O 0x10c0 [0x10c1]
                            I/O 0x10b4 [0x10b5]
etc.  Copy down the first 2 numbers EXACTLY as they appear (including spaces, 
brackets, etc).  Reboot your installation again.  At the boot:  prompt at the 
first screen, type: linux ide2=0x10c0 [0x10c1],0x10b6 [0x10b7] and then press 
enter.  The installation will start and it should recognize your hard disks.  
There is a HowTo about this at http://www.europe.redhat.com/documentation/mini-
HOWTO/Ultra-DMA-5.php3.  A couple notes:  You must add two to the second number
(s).  If you notice the nubers I had from the I/O printout, b4 and b5 become b6 
and b7 when you enter it at the boot: prompt.  I don't know why, but that is 
the way it has to be.  Also, you have to boot up in text mode when you finally 
get RH installed and enter in that line again before booting into RH.  I have 
not figured out how to get around that.  There is a patch for the kernel, but I 
haven't figured out how to use it yet.  I think there might be a way to write 
that line into lilo or the kernel itself, but I don't know how to do that.  
Anyone that knows, please let me know.  I am new to Linux, so any help would be 
appreciated.  If you have any questions, please feel free to contact me by 
email.  Hope this helps!
Comment 20 Alan Cox 2003-06-08 16:38:49 EDT
Should be resolved with modern errata kernels. If not please file a new bug
giving version, IDE information and an lspci  -v


Note You need to log in before you can comment on or make changes to this bug.