This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 420971 - SELinux is preventing sh (cupsd_t) "getattr" to /usr/bin/hpijs (hplip_exec_t).
SELinux is preventing sh (cupsd_t) "getattr" to /usr/bin/hpijs (hplip_exec_t).
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
: 426282 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 00:59 EST by Joe Buck
Modified: 2007-12-21 02:54 EST (History)
3 users (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-21 02:54:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Buck 2007-12-12 00:59:26 EST
Description of problem:

After a recent yum upgrade, printing on my HP Laserjet 1200 no longer works;
the first attempt to print gives the messsage in the summary.

Version-Release number of selected component (if applicable):

selinux-policy-2.6.4-61.fc7


How reproducible:

Every time.

Steps to Reproduce:
1. Attempt to print.
2. See "AVC Denial"
3. Look in setroubleshoot window for the message.
  
Actual results:

Printer queue goes to status "stopped".  Wife yells at me because she can't print.

Expected results:

Printed documents.

Additional info:

There were a number of related problems reported against Fedora 8 (eg #401411),
but the symptoms are different and the suggested workarounds don't apply. It
looks like this is a distinct (though related) bug.
Comment 1 Daniel Walsh 2007-12-12 10:51:19 EST
Fixed in selinux-policy-2.6.4-62.fc7
Comment 2 Gustavo Maciel Dias Vieira 2007-12-18 12:48:43 EST
Where can I download this package? Any other workaround while this doesn't hit
updates?
Comment 3 Daniel Walsh 2007-12-18 13:35:07 EST
Should be going into Fedora-testing soon.

You can grab it under

http://people.fedoraproject.org/~dwalsh/F7

This is also a yum repo
Comment 4 Gustavo Maciel Dias Vieira 2007-12-19 10:58:08 EST
I've installed the new version and it fixed the problem. Thanks.
Comment 5 Tim Waugh 2007-12-20 07:25:15 EST
*** Bug 426282 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.