Bug 421111 - kernel 2.6.23.8-34.fc7: no sound from Audigy2 EX
kernel 2.6.23.8-34.fc7: no sound from Audigy2 EX
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 04:27 EST by Jurgen Kramer
Modified: 2008-01-04 08:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-04 08:54:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jurgen Kramer 2007-12-12 04:27:47 EST
Description of problem:
With kernel 2.6.23.8-34.fc7 I no longer get sound from my SB Audigy2

Version-Release number of selected component (if applicable):
kernel-2.6.23.8-34.fc7

How reproducible:
always

Steps to Reproduce:
1. Boot kernel 2.6.23.8-34.fc7
2. Try out any sound app
3.
  
Actual results:
No sound at all.

Expected results:
Sound from my speakers.

Additional info:
With kernel 2.6.23.1-21.fc7 sound is still there. The speakers are connected
through SP/DIF out on the breakout module.

Relevant lspci output:
05:01.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
05:01.1 Input device controller: Creative Labs SB Audigy Game Port (rev 04)
05:01.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port (rev 04)

My card is a SB Audigy2 which needs:
Installing spdif_bug patch: Audigy 2 EX [1005]
this message is seen on both the working and non working kernel.

Modifying mixer settings (Audigy Analog/Digital Output Jack and IEC958 Optical
Raw) does not help.
Comment 1 Jurgen Kramer 2008-01-03 12:30:36 EST
OK with the latest kernel 2.6.23.12-52.fc7 (installed today) I still can't get
sound out of the SP/DIF. There is sound through the headphones. The latest
kernel which gives me sound is 2.6.23.1-21.fc7.

Running alsactl restore gives:alsactl: set_control:991: warning: name mismatch
(IEC958 Playback Default/IEC958 Playback Mask) for control #180
alsactl: set_control:993: warning: index mismatch (0/3) for control #180
alsactl: set_control:995: failed to obtain info for control #180 (Operation not
permitted)

Maybe this has something to do with it.
Comment 2 Jurgen Kramer 2008-01-04 08:54:36 EST
comparing the source from the emu10k1 driver for both 1-21 and 12-52 showed
nothing changed so I look elsewhere. After deleting both /etc/alsa/alsa.conf and
/etc/alsa/asound.state I now have my sound back from the coaxial SP/DIF output
on the LiveDrive. So not a bug but strange nonetheless.

Note You need to log in before you can comment on or make changes to this bug.