This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 42114 - End key does not work in xterm
End key does not work in xterm
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tcsh (Show other bugs)
7.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-24 08:07 EDT by Philip Rowlands
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-28 10:32:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Rowlands 2001-05-24 08:07:56 EDT
I'm using RH 7.1, with all errata applied. My shell is /bin/tcsh, and I'm
having problems with the End key inside xterm. Home works as expected.

To reproduce, set shell to /bin/tcsh, and start xterm.
The exact problem is exhibited as follows:
("_" is the cursor)
% abcdefg_	(HOME)
% _abcdefg	(END)
(terminal bell beeps)
% ~_abcdefg
% echo $TERM
xterm
% infocmp xterm | grep kend
  kend=\E[4~, kent=\EOM, kf1=\EOP, kf10=\E[21~, kf11=\E[23~,
% bindkey | grep ^end
end            -> end-of-line

I think this is caused by a recent change, because I can ssh to a RH 7.0
box and everything works fine.
Comment 1 Eido Inoue 2001-07-24 00:38:59 EDT
by removing the KANJI hacks this allowed some codes to get through to allow the
end key (and others to work).

Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.