Bug 421261 - crash on startup: 'module' object has no attribute 'arch
Summary: crash on startup: 'module' object has no attribute 'arch
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: KDE4Live
TreeView+ depends on / blocked
 
Reported: 2007-12-12 12:08 UTC by Sebastian Vahl
Modified: 2018-04-11 19:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-11 18:44:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sebastian Vahl 2007-12-12 12:08:04 UTC
Description of problem:
system-config-display crashs on startup with following output:

Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 294, in <module>
    vc = rhpxl.videocard.VideoCardInfo()
  File "/usr/lib/python2.5/site-packages/rhpxl/videocard.py", line 149, in 
__init__
    elif rhpl.arch.getCanonArch() == "ppc64pseries":
AttributeError: 'module' object has no attribute 'arch



Version-Release number of selected component (if applicable):
system-config-display-1.0.51-4.fc8

How reproducible:
ever

Steps to Reproduce:
1. start system-config-display from a terminal
2. watch output
  
Actual results:
app is crashing

Expected results:
app is working

Additional info:
I've set priority to "high" because this is one of my (personal) blockers for 
releasing the fedora kde4 livecd.

Comment 1 Matěj Cepl 2007-12-12 17:50:42 UTC
What's the architecture of the computer in question? Is it really i386 or ppc64?

Comment 2 Sebastian Vahl 2007-12-12 17:56:19 UTC
It's i386. (That's why I set the hardware tab to it).

Comment 3 Sebastian Vahl 2007-12-12 18:10:19 UTC
smolt profile: 
http://www.smolts.org/show?UUID=d52e288e-d14f-4568-b13e-5fe04a274686

Comment 4 antonio montagnani 2007-12-13 07:32:36 UTC
http://www.smolts.org/show?UUID=f695c0e1-a900-49cf-863b-360d139002b1

same here

Comment 5 Jeremy Katz 2007-12-17 20:10:05 UTC
Fixed up for rhpxl-0.49-3.

Comment 6 Thorsten Scherf 2007-12-18 13:00:27 UTC
works with rhpxl-0.49-3


Comment 7 Sebastian Vahl 2007-12-18 21:11:00 UTC
(In reply to comment #6)
> works with rhpxl-0.49-3

confirmed



Comment 8 Adam Jackson 2008-02-11 18:44:26 UTC
Closing.


Note You need to log in before you can comment on or make changes to this bug.