Bug 421391 - rsyslog and syslog-ng prevent "yum updates"
rsyslog and syslog-ng prevent "yum updates"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rsyslog (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 08:32 EST by Greg Morgan
Modified: 2015-07-21 09:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-18 05:26:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Morgan 2007-12-12 08:32:25 EST
Description of problem:
It is known that rsyslog will be the preferred logging tool in f8
http://lwn.net/Articles/242137/  When I performed a "yum update"
I receive "Error: rsyslog conflicts with syslog-ng"  The yum list rsyslog
syslog-ng shows that the syslog-ng package was installed somehow.  I am guessing
 that
1.) some package has a dependency on syslog-ng because I don't recall asking for it.
2.) Perhaps using the alternatives configuration tool would help make these two
packages co-exist.  Preference could co to the rsyslog package.

Version-Release number of selected component (if applicable):
yum list rsyslog syslog-ng
Installed Packages
rsyslog.i386                             1.19.10-1.fc8          installed       
syslog-ng.i386                           2.0.5-1.fc8            installed       
Available Packages
rsyslog.i386                             1.19.11-1.fc8          updates  


How reproducible:
There have been several reports http://fedoraforum.org/forum/showthread.php?t=174349
http://www.nabble.com/yum-dependencies:--rsyslog-versus-syslog-ng-td14262351.html


Steps to Reproduce:
1. Perform an update of the system around 12/10/2007
2. yum update
3.
  
Actual results:
No update performed.  Receive 
Error: rsyslog conflicts with syslog-ng

Expected results:
A clean update.

Additional info:

The work around is to use
yum update --exclude=rsyslog --exclude=syslog-ng
But if the updates are security updates, for either of these packages, then this
is not a good solution but it will update all the rest of the system.

After having more time to research the solution a better fix is to 
1.)  yum remove syslog-ng
...
Transaction Test Succeeded
Running Transaction
  Erasing   : syslog-ng                    ######################### [1/1] 

Removed: syslog-ng.i386 0:2.0.5-1.fc8
Complete!
...

2.)  yum update
...
Transaction Test Succeeded
Running Transaction
  Updating  : rsyslog                      ######################### [1/2] 
  Cleanup   : rsyslog                      ######################### [2/2] 

Updated: rsyslog.i386 0:1.19.11-1.fc8
Complete!

3.) yum list rsyslog syslog-ng
Installed Packages
rsyslog.i386                             1.19.11-1.fc8          installed       
Available Packages
syslog-ng.i386                           2.0.5-1.fc8            fedora
Comment 1 Peter Vrabec 2007-12-18 05:26:44 EST
hi, 
we decided to use use conflicts directive in rsyslog/syslog-ng because it 
makes troubles when both packages were installed. User can choose which one he 
wants to use. Your workaround is actually the right way, how to do it.

Note You need to log in before you can comment on or make changes to this bug.