Bug 421451 - kernel dm-snapshot: excessive memory usage
kernel dm-snapshot: excessive memory usage
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Milan Broz
Martin Jenner
:
: 383031 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 08:55 EST by Milan Broz
Modified: 2013-02-28 23:06 EST (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:03:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Broz 2007-12-12 08:55:25 EST
+++ This bug was initially created as a clone of Bug #383031 +++

Description of problem:

Using the device mapper snapshot of an origin device to simulate a CoW devices
causes progressive memory exhaustion as the device is written to.
...

This bugzilla covers backporting of a simple implementation of consecutive
exceptions for in-memory storage structure.
Using consecutive counter has huge memory saving impact in some snapshot
configuration (and doesn't increase memory use otherwise).

See
http://www2.kernel.org/pub/linux/kernel/people/agk/patches/2.6/editing/dm-snapshot-combine-consecutive-exceptions-in-memory.patch
Comment 1 RHEL Product and Program Management 2007-12-12 09:05:46 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Don Zickus 2007-12-21 15:18:42 EST
in 2.6.18-62.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 6 Mike Gahagan 2008-01-29 18:10:25 EST
Confirmed the -75 kernel is using less memory with the provided testcase. 

[root@test177 snapshot_verify]# cat snapslab-2.6.18-75.el5
dm-snapshot-in      1533   3128    112   34    1
dm-snapshot-ex      6982   9856     32  112    1

[root@test177 snapshot_verify]# cat snapslab-2.6.18-53.1.4.el5
dm-snapshot-in      1317   2380    112   34    1
dm-snapshot-ex     24724  27888     32  112   1

Other than the increase memory usage, both kernels seemed to hold up well. I was
never able to reproduce any corrupted snapshots or other errors.

I am pretty close to having the reproducer ready to go in RHTS.
Comment 7 Bryn M. Reeves 2008-02-08 04:32:11 EST
*** Bug 383031 has been marked as a duplicate of this bug. ***
Comment 10 errata-xmlrpc 2008-05-21 11:03:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.