Bug 42171 - Installer hangs several seconds after selecting installation type
Installer hangs several seconds after selecting installation type
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-05-24 12:57 EDT by Kyle Gonzales
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-06-06 08:58:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kyle Gonzales 2001-05-24 12:57:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2smp i686; en-US; rv:0.9)

Description of problem:
On a machine that ran Red Hat 6.2 without issues, I get hung on the
installer shortly after choosing the installation type.  Normally I chose
custom install, but it also hung choosing server install, or even booting
into rescue mode.  I am using the text install, because I do not have a
mouse attached to the machine.

The last console message I saw says something about 92 meg swap to 196 meg
swap.  The hard drive has been wiped clean of partitions before
installation.  The system will install Red Hat 6.2 without problems.

System hardware:
Pentium 233 MMX
Micronics Twister AT (Intel TX chipset mobo)
4 x 16 meg 70ns 72-pin memory
3.2 gig UDMA33 Fujitsu hard drive
24x Panasonic IDE CDRom
Netgear FA310 PCI NIC
Netgear FA311 PCI NIC
ATI Xpert98 PCI video card

How reproducible:

Steps to Reproduce:
1. Use CDRom install using retail known-good disks
2. Choose text install or rescue mode
3. Wait! (grin)

Actual Results:  System hangs 10 to 15 seconds after choosing the
installation type.

Expected Results:  System should continue on, and let me install Red Hat 7.1.

Additional info:
Comment 1 Brent Fox 2001-05-24 23:42:51 EDT
Do you see any messages on VC3 and VC4?
Comment 2 Kyle Gonzales 2001-05-25 10:32:23 EDT
Yes.  The last message I saw was on VC3.  It was a message saying something
about making swap 92 meg to 196 meg.  Otherwise, I saw no error messages or any
sort on VC3 or VC4.  Once the install hangs, tho, I am not able to switch to
different VCs.  I assume this means the install hang is actually a system hang.
Comment 3 Kyle Gonzales 2001-05-30 15:34:17 EDT
Any further ideas or movement on this?  What other information do you need from me?
Comment 4 Brent Fox 2001-05-31 14:07:58 EDT
Can you try booting with 'linux ide=nodma' and see if that works?  Also, is the
machine here in the Meridian office?
Comment 5 Kyle Gonzales 2001-05-31 14:32:48 EDT
I will try the "linux ide=nodma" option tonight, and let you know what happens.

The machine is not in the building.  However, since it is my personal home
machine, I can bring it in tomorrow and let you look at it while I'm at work.
Comment 6 Brent Fox 2001-06-13 00:00:04 EDT
Any more info on this?
Comment 7 Kyle Gonzales 2001-06-13 08:27:41 EDT
Ack! Sorry, I forgot to update this! I tried the "ide=nodma" option, and it
worked perfectly! I'm damn happy to get the 6th different version of Red Hat on
this machine! (5.0, 5.1, 5.2, 6.0, 6.2, and now 7.1)

Thank you for the assistance! I'm sorry I forgot to update the ticket.
Comment 8 Brent Fox 2001-06-13 10:20:47 EDT
Ok...good.  What we need now is the exact cdrom drive model name.  If you could
attach the output of 'cat /proc/ide/hdc/model' (or whatever device your cdrom
is), that would help us know what devices are having these problems.  

I'm changing component to the kernel since they are maintaining this list.
Comment 9 Kyle Gonzales 2001-06-13 10:34:03 EDT
Will do.  I will have it for you tomorrow.  And THIS time, I won't forgot.  Promise!
Comment 10 Kyle Gonzales 2001-06-25 12:27:11 EDT
Yes, yes, I know I'm slow in responding.  Here is the results of the command:


This is the offending CD-ROM drive.

Note You need to log in before you can comment on or make changes to this bug.