Bug 421771 - ZynAddSubFX main window uses 100% cpu on KDE with latest fltk [NEEDINFO]
ZynAddSubFX main window uses 100% cpu on KDE with latest fltk
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: fltk (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 10:20 EST by Nigel Henry
Modified: 2009-01-09 02:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:31:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rdieter: needinfo? (cave.dnb)


Attachments (Terms of Use)

  None (edit)
Description Nigel Henry 2007-12-12 10:20:43 EST
Description of problem: 
This applies to both Fedora 7, and 8. Opening ZynAddSubFX on KDE results in 
100% CPU useage. Mouse pointer is juddery, and when hovered over Zyns main 
window the pointer is difficult to see, and move. I can click on minimize, and 
Zyn minimizes to the panel, and CPU useage returns to normal. The same applies 
if I open, for example my home directory, which then partially covers Zyns 
main window, the CPU useage drops significantly. 
 
If I click on close, then minimize, Zyn minimizes to the panel, and the small 
window opens on KDE, asking if I want to continue without saving. Clicking on 
this shuts down Zyn with no problems. The same applies if I click on banks, or 
edit synth boxes on Zyns main window, then minimize Zyn. The child windows 
open, and there are no problems selecting a patch, or in the case of the edit 
synth on, changing parameters. 
 
I posted this as a bug against ZynAddSubFX, but Anthony Green suggested it may 
be an fltk problem, so I removed fltk-1.1.8-0.4.r5750.fc8, and replaced it 
with fltk-1.1.7-1.fc5 from my FC5 install, where Zyn (on the same machine) 
works ok. ZynAddSubFX now works fine on Fedora 8. I havn't tried the same on 
Fedora 7, where I have the same problem, but expect the FC5 version of fltk to 
resolve the problem there as well. 
 
I had also posted the Zyn problem to the planetccrma list, to see if anyone 
using KDE, had similar problems with Zyn. Someone replied saying it worked ok 
for him on KDE, so it may be a problem with the F7, and F8 version of fltk, 
and some graphics cards, my cyberbladei1 (trident driver) for example. 
 
BTW. Zyn works ok on F7, and F8, if I run it on Gnome, but not on KDE. 
 
As I've said, I havn't yet tried the FC5 version of fltk on F7, which has 
fltk-1.1.8-0.3.r5750.fc7, but if a strace output for the current fltk, and 
another for the FC5 version of fltk would be of any help, I'll go for it. 
 
Nigel. 
 
Version-Release number of selected component (if applicable): 
Fedora 7 fltk-1.1.8-0.3.r5750.fc7 
Fedora 8 fltk-1.1.8-0.4.r5750.fc8 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. 
2. 
3. 
   
Actual results: 
 
 
Expected results: 
 
 
Additional info:
Comment 1 Rex Dieter 2007-12-12 13:00:50 EST
Let's see if I can whip up a new snapshot test build.
Comment 2 Rex Dieter 2008-02-19 08:27:51 EST
In the meantime, may be worthwhile reporting this issue to the upstream fltk
bugtracker:
http://www.fltk.org/str.php
Comment 3 Rex Dieter 2008-02-19 08:31:38 EST
Further, here's the latest upstream snapshot, scratch build for f8:
http://koji.fedoraproject.org/koji/taskinfo?taskID=442052

Let me know when/if you have a chance to test this and/or report this upstream.
Comment 4 Jim Haynes 2008-08-08 19:15:01 EDT
This may be related to a bug I was about to report.  I have an application
that uses fltk.  I didn't write it, but I compile it from source.  When
I do so under F8 and F9 and run it the X server takes up about 50% of the
CPU.  I compiled fltk myself without Xinerama enabled and the application
linked with that works fine, quite low X server CPU usage.  I don't need
Xinerama, only have one monitor.  The only obvious difference between the
two versions of the linked program is that the slow one includes Xinerama
and the fast one does not.  So it appears there is some terrible inefficiency
with the fltk and Xinerama combination when Xinerama is not needed.
Comment 5 Bug Zapper 2008-11-26 03:58:04 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2009-01-09 02:31:43 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.