Bug 42193 - ls has changed its default ordering
Summary: ls has changed its default ordering
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fileutils   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-24 19:26 UTC by Paul Michael Reilly
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-24 19:26:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Michael Reilly 2001-05-24 19:26:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2smp i686; en-US; 0.8.1)
Gecko/20010425

Description of problem:
.xxx files are now listed according to XXX instead of placing them first as
a group.

How reproducible:
Always

Steps to Reproduce:
1.type ls -al
2.see that .*** files are no longer grouped together before ***
3.
	

Additional info:

Comment 1 Bernhard Rosenkraenzer 2001-05-25 10:52:54 UTC
Locale-awareness is a feature, not a bug.
If you want to turn it off, export LC_COLLATE=C


Comment 2 Adam Thompson 2001-06-07 02:45:14 UTC
Sorry.  Anything that *BREAKS* scripts after an upgrade IS NOT A FEATURE.

I don't **CARE** if it's POSIX-compliant behaviour, it is inappropriate 
behaviour for an out-of-the-box install.

Maybe that means making the default locale "C" again instead of en_US or 
en_whatever, since I don't recall any way to select the C locale during install.

...like I really needed another excuse to switch to BSD instead of upgrading a 
dozen RedHat customers to 7.1.  Much as I dislike "for historical reasons" 
showing up in the manpage, /bin/ls is critical enough to way too many scripts 
to change DEFAULT behaviours.

(Besides - since when does "." get ignored during collation?  It has a position 
in any collation order.  Maybe before alphas maybe after, but I don't expect 
collation to simply IGNORE characters it doesn't feel like sorting.)



Note You need to log in before you can comment on or make changes to this bug.