Bug 42194 - statfs() (or some similar function) is broken
Summary: statfs() (or some similar function) is broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.1
Hardware: sparc Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-24 20:02 UTC by Jason Duerstock
Modified: 2016-11-24 14:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-01 13:01:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Duerstock 2001-05-24 20:02:34 UTC
Description of Problem:
Under 2.4.x kernels, df -k returns erroneously returns 0 available space.

How Reproducible:


Steps to Reproduce:
1. boot 2.4.x kernel
2. df -k
3. 

Actual Results:
[jason@localhost jason]$ df -k
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/hda1              8222624   3279368         0 100% /

Expected Results:
3000000-some-odd free blocks.

Additional Information:
I believe this is a glibc problem and not a fileutils problem, because if 
I try to install additional packages with rpm, it tells me there is 
insufficient space available.

Comment 1 Jakub Jelinek 2001-06-01 12:29:03 UTC
There is no 7.1 distribution for SPARC. Do you mean Rawhide, or 6.2?

Comment 2 Jason Duerstock 2001-06-01 13:01:51 UTC
err, sorry about that...this is from rawhide.


Comment 3 Jakub Jelinek 2002-02-04 14:58:16 UTC
If this was on sparc64 kernel combined witl gcc-2.96-RH, then this might
be miscompilation of ext2 (which is fixed in gcc-2.96-102 as found on
ftp://ultra.linux.cz/private/VOL4/aurora/new-gcc/).


Note You need to log in before you can comment on or make changes to this bug.