Bug 422021 - include liveinst.desktop in favorites menu
include liveinst.desktop in favorites menu
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Sebastian Vahl
Fedora Extras Quality Assurance
:
Depends On:
Blocks: KDE4Live
  Show dependency treegraph
 
Reported: 2007-12-12 12:13 EST by Sebastian Vahl
Modified: 2008-01-09 08:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 08:07:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2007-12-12 12:13:09 EST
Include liveinst.desktop in favourites menu in new kde4 menu. This is IMHO the 
best place to put the live image installer since old kdesktop with icons is 
gone.

Additional info:
See this bug as a personal reminder and blocker. :) But if someone know a 
solution please drop a comment.
Comment 1 Kevin Kofler 2007-12-12 12:48:57 EST
There's an applet worked on to show the desktop icons in Plasma, it just hasn't 
made it into kdebase-workspace or extragear-plasma yet:
http://websvn.kde.org/trunk/playground/base/plasma/applets/desktop/
Comment 2 Sebastian Vahl 2007-12-12 13:07:15 EST
That could be one solution. But having it also in favorites menu would be 
good, IMHO. I've tried to copy that file manually into the favourites menu 
file but that doesn't work either.
I'll try to figure out which of my older live images still work (related to 
bug #422061) and try to reproduce my steps.  AFAIR the menu file (I don't 
actual remember the name) would be overwritten by some other process during 
startup.
Comment 3 Sebastian Vahl 2007-12-12 17:51:22 EST
Ok. I've found a bootable live image and was also able to put liveinst.desktop 
in the menu file. I've just put a short script in livecd-fedora-kde.ks to 
create a /home/fedora/.kde/share/config/kickoffrc with the content:

# add liveinst.desktop to favorites menu
mkdir -p /home/fedora/.kde/share/config/
cat > /home/fedora/.kde/share/config/kickoffrc << MENU_EOF
[Favorites]
FavoriteURLs=/usr/share/applications/kde4/konqbrowser.desktop,/usr/share/applications/kde4/dolphin.desktop,/usr/share/applications/liveinst.desktop
MENU_EOF
chown -R fedora:fedora /home/fedora/.kde/share/

I will leave this bug open until I'm really able to test this (related to bug 
#422061).
Comment 4 Kevin Kofler 2007-12-13 02:18:38 EST
Apparently, the reason the desktop plasmoid in playground is no longer being 
worked on is that they're adding support for desktop icons to the default 
Plasma desktop, see:
http://dot.kde.org/1197405276/1197441103/1197514113/
http://lists.kde.org/?l=kde-panel-devel&m=119735028308801&w=2
So we'll just have to wait a bit and then it will be just a setting to enable 
in kde-settings (it'll be off by default upstream).
Comment 5 Sebastian Vahl 2007-12-13 08:52:24 EST
Sounds good! We will see how usuable it is.
Comment 6 Sebastian Vahl 2008-01-09 08:07:27 EST
With kde-4.0.0 packages there is also an icon on the desktop. But I'm not sure 
how it gets there. /home/fedora/Desktop/liveinst.desktop is present but I'm 
not copying it there.

However. I'm closing this bug because problem is fixed.

Note You need to log in before you can comment on or make changes to this bug.