Bug 42212 - Multiple simultaneous logins (KDE) yields errors.
Multiple simultaneous logins (KDE) yields errors.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-24 16:25 EDT by Rex Dieter
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-29 12:42:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2001-05-24 16:25:59 EDT
Description of Problem:
When logging in to multiple machines with shared home directories (NFS) 
to kde sessions, only the current one works completely.  Previous 
concurrent logins cannot lauch programs via KDE panel.

How Reproducible: every time

Steps to Reproduce:
1. login to machine a into KDE session
2. login to machine b into KDE session (same user)
3. go back to machine a, and try to launch a program from the KDE menu.  
It sometimes works once, but not more than that.  Afterward, every 
attempted program launch yields error:
Sorry - KDE Panel
! Couldn't launch konqueror (or whatever your program may be).

I used to successfully login multiple times when I used KDE 2.0.1 on 
RedHat 6.2.
Comment 1 Rex Dieter 2001-05-29 12:42:13 EDT
I found the root cause of this problem.  It's a section of the startkde script:
rm -f ~/.DCOPserver*

If I comment this out, the problem goes away.  Unfortunately, this leads to lots
of ~/.DCOPserver_`hostname` files laying around, but that's better than
non-functional kde sessions.
Comment 2 Bernhard Rosenkraenzer 2001-08-13 09:51:49 EDT
Fixed in 2.2-3

Note You need to log in before you can comment on or make changes to this bug.