Bug 42222 - EFI boot option "Red Hat Linux" fails after install
EFI boot option "Red Hat Linux" fails after install
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnu-efi (Show other bugs)
7.3
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-24 19:18 EDT by Ben Levenson
Modified: 2014-03-16 22:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-05 14:16:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2001-05-24 19:18:23 EDT
Description of Problem:
build qa0523.0
"Red Hat Linux" boot option from the EFI boot manager doesn't always work.

How Reproducible:
This is only an issue for the first couple of reboots after doing an 
install.  It will eventually start working.

Steps to Reproduce:
1. Perform an install
2. reboot
3. allow system to automatically boot from the first boot option
   in the EFI Boot Manager: "Red Hat Linux"

Actual Results:
If I'm lucky the following error message will be displayed and I will be
spit out at the efi shell:
Loading.:Red Hat Linux
Starting:Red Hat Linux
ELILO
elilo.c (line 74): Cannot find a loader for
Start of Red Hat Linux failed: Lead Error

Sometimes this happens when I manually select the Red Hat option and
press "Enter":
Loading.:Red Hat Linux
Starting:Red Hat Linux
ELILO
and then the system hard-locks.

Additional Information:
Boot option configuration: 
HD(Part1,Sig00000000)/\elilo.efi
Boot0006

This behavior seems pretty random, but in general it seems to happen
during the first few boot attempts.  Eventually the situation straightens
itself out and then seems to be fixed for good.
Comment 1 Ben Levenson 2001-05-25 11:34:54 EDT
filed under the wrong arch. changing to ia64.
also...unsure of component...filed under gnu-efi 
Comment 2 Bill Nottingham 2001-06-05 14:15:58 EDT
This should be fixed in elilo-2.5-3.
Comment 3 Ben Levenson 2001-06-07 17:59:10 EDT
fix verified qa0607.3
elilo-2.5.3

closing

Note You need to log in before you can comment on or make changes to this bug.