Bug 422271 - Drop in support for logrotate
Drop in support for logrotate
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
Gurhan Ozen
:
Depends On:
Blocks: 391501 409971 449772
  Show dependency treegraph
 
Reported: 2007-12-12 13:42 EST by Adam Stokes
Modified: 2013-11-03 20:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:15:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file patch for logrotate support (1.04 KB, patch)
2007-12-12 13:42 EST, Adam Stokes
no flags Details | Diff
logrotate config (98 bytes, text/plain)
2007-12-12 13:42 EST, Adam Stokes
no flags Details
Proposed logrotate config (197 bytes, text/plain)
2008-07-10 08:42 EDT, Daniel Berrange
no flags Details

  None (edit)
Description Adam Stokes 2007-12-12 13:42:16 EST
Description of problem:
Xen logging of several xen commands will eventually fill up disk space.

Version-Release number of selected component (if applicable):
xen-3.0.3-41.el5

How reproducible:
100%

Steps to Reproduce:
1. Run any combinations of xen commands
2.
3.
  
Actual results:
Logs fill up and so does disk space

Expected results:
Check the following log files size and rotate(logrotate?) it.
/var/log/xen/qemu-dm.*.log
/var/log/xen/xen-hotplug.log
/var/log/xen/xend-debug.log
/var/log/xen/console/*.log
/var/log/xen/domain-builder-ng.log

Additional info:
Comment 1 Adam Stokes 2007-12-12 13:42:16 EST
Created attachment 286001 [details]
Spec file patch for logrotate support
Comment 2 Adam Stokes 2007-12-12 13:42:49 EST
Created attachment 286011 [details]
logrotate config
Comment 3 Mark McLoughlin 2008-01-02 09:55:35 EST
See bug #234594 on why we went with:

/var/log/xen/xend-debug.log /var/log/xen/xen-hotplug.log
/var/log/xen/domain-builder-ng.log {
    notifempty
    missingok
    copytruncate
}

in Fedora, in particular that we didn't do *.log since xend.log is already
rotated by xend.
Comment 4 Daniel Berrange 2008-01-02 10:03:19 EST
RHEL-5.3 doesn't even exist yet, changing component version to more a sensible 5.1
Comment 5 Daniel Berrange 2008-01-02 10:05:20 EST
We previously punted on this issue for 5.1, but we should consider it for 5.2
since it is an easy change to make and solves a real problem. Equivalent change
is already in Fedora 8 and later.

Comment 6 RHEL Product and Program Management 2008-01-02 10:14:35 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Issue Tracker 2008-01-04 03:31:43 EST
From Fujitsu:

1)/var/log/xen/qemu-dm.*.log
 should be fixed by logrotate

2)/var/log/xen/xen-hotplug.log
 should be fixed by logrotate

3)/var/log/xen/xend-debug.log
 same as 5)

4)/var/log/xen/console/*.log
 should be fixed by logrotate

5)/var/log/xen/domain-builder-ng.log

> How is to restart the xend daemon after this logfile is rotated by
logrotate?
> We should be able to use "postrotate ... endscript" in the  logrotate
configuration.

It is impossible because of the same reason as
3)/var/log/xen/xend-debug.log.
Xend does not close this file. We consider that xend needs to be modified
or restarted.



This event sent from IssueTracker by mmatsuya 
 issue 138413
Comment 8 Daniel Berrange 2008-01-04 08:54:48 EST
There is no need to restart Xend after rotating the xend-debug.log - the
'copytruncate' directive in the logrotate file deals with the issue of XenD not
closing the file by truncating it to 0 bytes after it has been rotated.
Comment 11 RHEL Product and Program Management 2008-06-02 16:26:29 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 14 Daniel Berrange 2008-07-10 08:42:10 EDT
Created attachment 311474 [details]
Proposed logrotate config
Comment 16 Daniel Berrange 2008-07-21 07:29:31 EDT
Built into xen-3.0.3-68.el5
Comment 19 errata-xmlrpc 2009-01-20 16:15:17 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0118.html

Note You need to log in before you can comment on or make changes to this bug.