Bug 422341 - 3.38: Add proper needinfo actor support to multi edit bug list
3.38: Add proper needinfo actor support to multi edit bug list
Status: CLOSED DUPLICATE of bug 406451
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
3.2
All Linux
high Severity low (vote)
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks: RHBZ30UpgradeTracker
  Show dependency treegraph
 
Reported: 2007-12-12 14:40 EST by David Lawrence
Modified: 2013-06-24 00:17 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-21 16:37:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add needinfo? for multi bug edit in process_bug.cgi (1.46 KB, patch)
2007-12-12 14:58 EST, David Lawrence
no flags Details | Diff
Patch to add needinfo? for multi bug edit in process_bug.cgi (v2) (896 bytes, patch)
2007-12-12 15:01 EST, David Lawrence
no flags Details | Diff

  None (edit)
Description David Lawrence 2007-12-12 14:40:30 EST
Currently when someone selects NEEDINFO status when edit several bugs at once in
buglist.cgi, it does not properly set the needinfo? flag. The same mechanism
that is present when editing a single bug report for automatically setting the
needinfo? flag with a requestee should be accessible from the multi edit page as
well. The requestee field should not be filled it with assignee, reporter, and
qa contact automatically since there are more than one value for those. But
choosing one of the actors should choose the proper value when process_bug.cgi
loops through the id list. Needinfo actor support will be redone for the 3.0
upgrade to be more simple and generic which should help with this.

buglist.cgi template/en/default/list/edit-multiple.html.tmpl
template/en/default/bug/knob.html.tmpl
Comment 1 David Lawrence 2007-12-12 14:58:45 EST
Created attachment 286101 [details]
Patch to add needinfo? for multi bug edit in process_bug.cgi

This is not optimal as it requires that the needinfo flag is not set to allow
'multiple' flags in the editflagtypes.cgi admin interface. If is set to allow
multiple, then more than one needinfo? flag could be set if people were to pick
the same bug again in the multi edit list when changing status to NEEDINFO and
the bug's status is already set to NEEDINFO.
Comment 2 David Lawrence 2007-12-12 15:01:08 EST
Created attachment 286121 [details]
Patch to add needinfo? for multi bug edit in process_bug.cgi (v2)

Had too much other changes in the last process_bug.cgi patch. This one is just
the needinfo change.
Comment 3 David Lawrence 2007-12-21 16:37:43 EST
This should be part of the overall needinfo actor strategy and will be tracked
from the base needinfo actory bug.

*** This bug has been marked as a duplicate of 406451 ***

Note You need to log in before you can comment on or make changes to this bug.