Bug 42251 - Truetype fonts randomly smaller!
Truetype fonts randomly smaller!
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-25 04:48 EDT by Jeremy Sanders
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-06 04:28:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config file (14.45 KB, text/plain)
2001-05-25 04:49 EDT, Jeremy Sanders
no flags Details
xfs config file (1.13 KB, text/plain)
2001-05-25 04:50 EDT, Jeremy Sanders
no flags Details
Real XFree86 configuration file (1.93 KB, text/plain)
2001-05-29 06:00 EDT, Jeremy Sanders
no flags Details
Log from X with broken fonts (18.68 KB, text/plain)
2001-05-29 06:01 EDT, Jeremy Sanders
no flags Details
Normal X log file (19.75 KB, text/plain)
2001-05-29 06:02 EDT, Jeremy Sanders
no flags Details
Screenshot with broken fonts (20.48 KB, image/png)
2001-05-29 06:03 EDT, Jeremy Sanders
no flags Details
Screenshot in normal state (20.02 KB, image/png)
2001-05-29 06:04 EDT, Jeremy Sanders
no flags Details

  None (edit)
Description Jeremy Sanders 2001-05-25 04:48:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; rv:0.9+)
Gecko/20010523

Description of problem:
I'm not sure what causes this, but I find the truetype font I use in my
terminals and emacs (Andale Mono), sometimes, when I log in, comes out much
smaller than it was previously set.

Dropping to runlevel 3, and back to 5, and restarting xfs doesn't cure the
problem, but restarting linux does! I can't reproduce what causes the fonts
to change size.


How reproducible:
Sometimes

Steps to Reproduce:
1. Log in and out a few times (I suspect)
2.
3.
	

Additional info:
Comment 1 Jeremy Sanders 2001-05-25 04:49:34 EDT
Created attachment 19591 [details]
XF86Config file
Comment 2 Jeremy Sanders 2001-05-25 04:50:22 EDT
Created attachment 19592 [details]
xfs config file
Comment 3 Mike A. Harris 2001-05-25 09:45:24 EDT
I'm willing to bet that you are starting an app, changing the font,
but aren't telling it to remember the font.


What desktop are you using, GNOME, or KDE?  Restarting Linux may seem
to solve the problem, however the Linux kernel has nothing to do with fonts.
Does "service xfs stop" followed by "service xfs start" fix it?
Comment 4 Jeremy Sanders 2001-05-25 10:12:58 EDT
No - that's the odd thing. Restarting xfs didn't help, which doesn't make sense
at all!! I know xfs isn't connected to the kernel. I'm using GNOME.

The steps were:
 o Log in - my gnome-terminal fonts we at 3/4 the size
 o Log out
 o Log in - still the same
 o Log out
 o Switch to runlevel 3, restart xfs, go back to runlevel 5
 o Log in - fonts still small
 o Log out
 o Restart machine
 o Log in - fonts restored!!!

I don't save the "Save settings" command enabled on gnome on logout, and I
didn't change any font settings.

Really odd. I may have restarted xfs with xfs restart instead of stop,start, so
I'll have to try and make it happen again, so I'll be able to pin the bug
further down. It's an annoying bug, as it's so hard to pin down!
Comment 5 Mike A. Harris 2001-05-25 10:42:58 EDT
service xfs restart is not the same as service xfs stop then start.
If in doubt, as root do "killall -9 xfs" then "service xfs start".
Comment 6 Jeremy Sanders 2001-05-29 05:59:19 EDT
Okay. Firstly, the above XF86Config file is wrong. I'm using X4, and the config
file is the V3 one.

Right, dropping to runlevel 3, stopping xfs, starting xfs, and going back to RL5
doesn't fix the problem!! I'm going to attach screenshots to demonstate the
"normal" and "broken" states. The problem was fixed on restarting the machine.

Looking at the XFree86 log files, I suspect the problem's due to the Matrox G400
card getting in a funny state on X restart. The font size screws up as X can't
get the DDC information about the monitor. It's a card or driver fault (I
think), as turning the monitor on and off before starting X doesn't help. From
the X log files, the vital parts are:

[normal]
> (II) MGA(0): DDC Monitor info: 0x82fe540
> (II) MGA(0): Manufacturer: IVM  Model: 1901  Serial#: 0
> (II) MGA(0): Year: 1999  Week: 3
> (II) MGA(0): EDID Version: 1.1
> (II) MGA(0): Analog Display Input,  Input Voltage Level: 0.700/0.300 V
> (II) MGA(0): Sync:  Separate  Composite  SyncOnGreen
> (II) MGA(0): Max H-Image Size [cm]: horiz.: 36  vert.: 27
> (II) MGA(0): Gamma: 2.10
> (II) MGA(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
> (II) MGA(0): redX: 0.625 redY: 0.340   greenX: 0.290 greenY: 0.605
> (II) MGA(0): blueX: 0.149 blueY: 0.016   whiteX: 0.283 whiteY: 0.297
> (II) MGA(0): Supported VESA Video Modes:
> (II) MGA(0): 640x480@60Hz
> (II) MGA(0): 640x480@67Hz
...
> (--) MGA(0): Display dimensions: (36, 27) cm
> (--) MGA(0): DPI set to (90, 96)

[broken]
< (II) MGA(0): DDC Monitor info: (nil)
< (==) MGA(0): DPI set to (75, 75)

So it looks like xfs isn't to blame, but it's a card/XFree driver bug.
Comment 7 Jeremy Sanders 2001-05-29 06:00:13 EDT
Created attachment 19856 [details]
Real XFree86 configuration file
Comment 8 Jeremy Sanders 2001-05-29 06:01:18 EDT
Created attachment 19857 [details]
Log from X with broken fonts
Comment 9 Jeremy Sanders 2001-05-29 06:02:10 EDT
Created attachment 19858 [details]
Normal X log file
Comment 10 Jeremy Sanders 2001-05-29 06:03:31 EDT
Created attachment 19859 [details]
Screenshot with broken fonts
Comment 11 Jeremy Sanders 2001-05-29 06:04:25 EDT
Created attachment 19860 [details]
Screenshot in normal state
Comment 12 Mike A. Harris 2001-06-19 00:45:22 EDT
Are you using a non-Red Hat kernel?  If so please recompile it with
MTRR support.  That should fix the write combining errors.

What does your /proc/cpuinfo and uname -a report?  Looks like there
might possibly be a bug in the DDC probe code.

Temporary workaround: Hardcode your monitor's DPI settings into the
config file.  "man XF86Config" for details.

Comment 13 Jeremy Sanders 2001-06-19 04:56:36 EDT
I'm using stock RedHat 2.4.2-2 on an Athlon. The MTRR stuff is described in bug
41856, and is fixed with a RawHide kernel.

xpc1:/scratch/jss> cat /proc/cpuinfo 
processor
: 0
vendor_id
: AuthenticAMD
cpu family	: 6
model
	: 4
model name	: AMD Athlon(tm) Processor
stepping
: 2
cpu MHz		: 1299.431
cache size	: 256 KB
fdiv_bug
: no
hlt_bug
	: no
f00f_bug
: no
coma_bug
: no
fpu
	: yes
fpu_exception
: yes
cpuid level	: 1
wp
	: yes
flags
	: fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr
syscall mmxext 3dnowext 3dnow
bogomips
: 2588.67

xpc1:/scratch/jss> uname -a
Linux xpc1.ast.cam.ac.uk 2.4.2-2 #1 Wed May 23 18:33:22 BST 2001 i686 unknown
Comment 14 Mike A. Harris 2002-02-05 23:36:19 EST
Do you still encounter this problem with the XFree86 4.1.0-15
update that was released?
Comment 15 Jeremy Sanders 2002-02-06 04:28:01 EST
I think it's fixed in RedHat 7.2. I haven't seen it again recently - probably
should close. Shall I reopen if I see it?

Note You need to log in before you can comment on or make changes to this bug.