Bug 422731 - RHEL 5.1 Firstboot with --reconfig option shows serious bugs
RHEL 5.1 Firstboot with --reconfig option shows serious bugs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firstboot (Show other bugs)
5.1
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 20:09 EST by Ronan Kirby
Modified: 2013-10-20 18:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-31 18:35:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronan Kirby 2007-12-12 20:09:07 EST
Description of problem:

With RHEL 5.1, x86_64: when a machine is kickstarted with the firstboot
--reconfig option used, then booted to the first screen of firstboot, nothing
clicked or entered, then hard-shutdown and booted again, multiple problems start
to show in firstboot....

Version-Release number of selected component (if applicable):
firstboot-1.4.27.3-1.el5

How reproducible:
Always

Steps to Reproduce:
1. Build machine with kickstart and the "firstboot --reconfig" option
2. Boot machine, till it rests on 1st screen of firstboot menu
3. Hard shutdown the machine and reboot
4. Proceed to use firstboot menu to experience errors
  
Actual results:
1. The language screen can on occasion be unresponsive when "next" is clicked. 

2. When it does progress, it jumps to the SELinux screen, though the red menu
bar on the left indicates it should be at the license screen menu.

3. Clicking next from there brings you to the date & time config page, though
the left hand menu says it should be the keyboard configuration page.

4. This changes from annoyance to problem here - when you click next on the
previous screen, it brings you to "choose server", for your RHN config
(satellite, proxy etc). However the left hand menu in red suggests it should be
the configure root password screen. When you click next on this screen, it says
"Root password must be at least 6 characters in length", but of course the
screen text and menu options are all relating to RHN. So you cannot progress
beyond this page.


Expected results:
Menu should function normally

Additional info:
This is a necessary function for a large project currently being deployed with
an OEM. The reason for the boot and then hard reboot is because the initial boot
of the system is done on the production line as a test. When the end user boots
the system, it will actually be the second time it's booted, but firstboot
functionality still required.
Comment 1 Mark McLoughlin 2007-12-14 09:41:24 EST
The actual reproducer here is:

  1) Boot into firstboot language selection screen

  2) Choose a different language and then immediately switch back to en_US
     before clicking next

  3) The notebook page doesn't agree with what's selected in the sidebar and
     everything is seriously screwed up

The fix appears to be:

         pageNum = len(self.notebook.get_children())
         for i in range(pageNum):
             self.notebook.hide()
-            self.notebook.remove_page(i)
+            self.notebook.remove_page(0)
Comment 2 Chris Lumens 2008-01-31 18:35:39 EST
I am closing this bug as WONTFIX, as I am proposing removing the language
selection screen entirely due to the fact that it is perpetually broken (as this
and other bugs attest) and that it is entirely misleading in what it
accomplishes.  Please refer to bug 431143 for tracking that resolution.

Note You need to log in before you can comment on or make changes to this bug.