Bug 42274 - FHS 2.2 mandates /etc/adjtime -> /var/lib/hwclock/adjtime
Summary: FHS 2.2 mandates /etc/adjtime -> /var/lib/hwclock/adjtime
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-25 14:27 UTC by Daniel Roesen
Modified: 2014-03-17 02:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-25 14:53:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Roesen 2001-05-25 14:27:35 UTC
Currently, the adjtime file resides in /etc, FHS 2.2 mandates
/var/lib/hwclock as proper path.

Subject: [ANNOUNCE] FHS 2.2 Released
Date: Thu, 24 May 2001 17:19:32 +1000

[...]
Major changes:
[...]
        o /var/lib/hwclock explicitly added for adjtime.
[...]
        o adjtime, disktab, fdprm, lilo.conf, ttytype removed from
          /etc examples.

Comment 1 Bill Nottingham 2001-05-25 14:40:17 UTC
That's dumb.

You want to sync your clock as soon as possible on bootup/as late as possible
on shutdown. Hence, you want to do it before other FS are mounted.

Moreover, this is not something external apps need to care about, so why
is the FHS even specifying it?

Comment 2 Daniel Roesen 2001-05-25 14:44:39 UTC
Don't shoot the messenger, I just cited the announcement I just have read. Dunno
what's the reasoning behind it... See Bug #42273 for a related change.

Comment 3 Bill Nottingham 2001-05-25 14:52:56 UTC
I'm not shooting the messenger, I'm just explaining why I'm probably
going to close this as WONTFIX. ;)


Note You need to log in before you can comment on or make changes to this bug.