Bug 42281 - g77 and ICHAR wrong results
g77 and ICHAR wrong results
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
: 52730 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-25 11:02 EDT by Nikos Baltas
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-06 11:08:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
testing ICHAR (192 bytes, text/plain)
2001-05-25 11:04 EDT, Nikos Baltas
no flags Details

  None (edit)
Description Nikos Baltas 2001-05-25 11:02:29 EDT
Description of Problem:

Using g77 (RedHatLinux7.0) the function ICHAR produces wrong results.
How Reproducible:
All the time.

Steps to Reproduce:

FORTRAN code:

       program test
       integer ic
       character*1 ch
       do 100 i=0,255
         ch=char(i)
         ic=ichar(ch)
         print *,ic
 100   continue
       end

Actual Results:
0,1,...,126,127,-128,-129,...-2,-1

Expected Results:
0,1,...,126,127,128,129,.....254,255

Additional Information:
Problem occurs with RH Linux7.0 and g77 version 2.96 (gcc 2.96).
Problem does not occur in previous version of RH Linux(5.1) with
the gcc version (egcs-2.90.27 980315 (egcs-1.0.2 release)
Comment 1 Nikos Baltas 2001-05-25 11:04:22 EDT
Created attachment 19610 [details]
testing ICHAR
Comment 2 Jakub Jelinek 2001-06-05 03:55:06 EDT
Fixed by Toon Moene in http://gcc.gnu.org/ml/gcc-patches/2001-06/msg00062.html,
this patch is already in the patchset for the upcoming gcc-g77-2.96-86.
Comment 3 Nikos Baltas 2001-06-06 11:08:36 EDT
Thanks for doing this.
How can I apply this patch to the current gcc installation?
Please advise.
Comment 4 Jakub Jelinek 2001-06-07 09:27:06 EDT
gcc-2.96-86 has been built earlier today, either you can grab it from
ftp://people.redhat.com/jakub/gcc/2.96-86/
or wait till it propagates through rawhide mirrors.
Comment 5 Jakub Jelinek 2001-08-28 11:03:38 EDT
*** Bug 52730 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.