Bug 422991 - Rhythmbox changing several music files
Rhythmbox changing several music files
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
7
All Linux
low Severity urgent
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 04:04 EST by Alessio Milan
Modified: 2008-03-14 06:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 06:36:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff of modified files (5.74 KB, text/plain)
2007-12-13 09:03 EST, Alessio Milan
no flags Details
rhythbox -d output (1.45 MB, application/x-gzip)
2007-12-20 05:35 EST, Alessio Milan
no flags Details
Screen dump (116.46 KB, image/png)
2008-01-10 06:24 EST, Alessio Milan
no flags Details

  None (edit)
Description Alessio Milan 2007-12-13 04:04:23 EST
Description of problem:
Every time I launch rhythmbox, it scans all the music library, even if nothing
changed from previous launch. Worse, it also changes some of the files. The
changed file are of some bytes longer.

Version-Release number of selected component (if applicable):
rhythmbox-0.10.1-5.fc7

How reproducible:
Simply running rhythmbox.


Steps to Reproduce:
1. Copy current music library to another folder
2. Launch rhythmbox. You will see it scanning music library
3. Wait until it finish scanning
4. Exit rhythmobox.
5. Compare current music library with the saved one. You will see several
changed files.
  
Actual results:
Several music files are changed.

Expected results:
No music file should be changed


Additional info:
This behavior started after last rhythmbox update
Comment 1 Bastien Nocera 2007-12-13 05:47:19 EST
I don't understand what you mean by "changing files".

Rhythmbox will scan the library on startup if you have "Watch my library for new
files" selected, and also to check that all the files referenced in the library
still exist.

It won't modify any library files unless you change the tags in the properties
window.
Comment 2 Alessio Milan 2007-12-13 08:43:59 EST
I mean that it modifies them, some of them, during the scan at startup. The
modified files are a little bigger than original but they didn't look broken.
Comment 3 Alessio Milan 2007-12-13 09:03:06 EST
Created attachment 287431 [details]
Diff of modified files

I restored original music files from a backup in a folder called music, then I 
typed the following commands:

cd music
ls -lR > ../list1.txt
rhythmbox
ls -lR > ../list2.txt
cd ..
diff list1.txt list2.txt > diff.txt

You can see several changed files after running rhythmbox (the library contains
two thousand files).
Comment 4 Bastien Nocera 2007-12-19 11:04:48 EST
I really don't see what could be causing this.

Do the files change sizes again for future runs? Could you please gather the
full output of "rhythmbox -d" when reproducing the problem from a backup?
Comment 5 Alessio Milan 2007-12-20 05:35:14 EST
Created attachment 290141 [details]
rhythbox -d output
Comment 6 Alessio Milan 2007-12-20 05:39:52 EST
It happens every time I launch the application. I reverted to
rhythmbox-0.10.0-8.fc7 and it works well as expected. It looks like a bug in
this specific version.

Other players like amaroK, exaile and Listen do not modify any file.
Comment 7 Alessio Milan 2008-01-10 06:24:34 EST
Created attachment 291266 [details]
Screen dump
Comment 8 Alessio Milan 2008-01-10 06:25:22 EST
I installed the update rhythmbox-0.10.1-7.fc7 but the issue is still there.

Searching for a workaround, I protected all folders under my music folder with
"chmod 555". Rhythmbox starts and rescan all the library and ends with a lot of
error messaging stating that it cannot write music information. See the
attachment above.

I think this is a issue too because rhythmbox can't run on read only devices as
cd-roms.
Comment 9 Bastien Nocera 2008-03-13 19:47:18 EDT
rhythmbox-0.10.0-8.fc7 works, but rhythmbox-0.10.1-5.fc7 doesn't.

Is there any chance you could test the versions in between?
rhythmbox-0.10.1-1.fc7
rhythmbox-0.10.1-2.fc7
rhythmbox-0.10.1-3.fc7
and
rhythmbox-0.10.1-4.fc7

All the builds are available in
http://koji.fedoraproject.org/koji/packageinfo?packageID=269

I also don't see any changes in the 0.10.1 ChangeLog that would cause your
problem. Which filesystem is your home directory running on?
Comment 10 Alessio Milan 2008-03-14 04:21:04 EDT
I just upgraded my Fedora 7 to Fedora 8. Version rhythmbox-0.11.3-7.fc8 works
well and the bug disappeared.
Comment 11 Bastien Nocera 2008-03-14 06:36:57 EDT
Good, let's put that one to bed.

Note You need to log in before you can comment on or make changes to this bug.