Bug 423031 - [ml_IN]Chillu Glyph is not appearing
[ml_IN]Chillu Glyph is not appearing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 05:10 EST by A S Alam
Modified: 2013-07-02 20:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 03:38:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ml_IN (9.10 KB, image/png)
2007-12-13 05:14 EST, A S Alam
no flags Details
Screenshot for Both Actual and Expected (34.34 KB, image/png)
2007-12-13 05:35 EST, A S Alam
no flags Details

  None (edit)
Description A S Alam 2007-12-13 05:10:05 EST
Description of problem:
Chillu Glyph is not appearing with consonants
 ര [0d30]/ റ [0d31] + 0d4d + 200d = ???
 ന [0d28]  + 0d4d + 200d =
 ല [0d32] +  0d4d + 200d =
 ള [0d33] + 0d4d + 200d =
 ണ [0d23] + 0d4d + 200d = 

Version-Release number of selected component (if applicable):
fonts-malayalam-2.1.5-3.fc8

How reproducible:
Everytime

Steps to Reproduce:
1. Open gedit
2. type above combination with scim-rawcode
3.
  
Actual results:
Virma (0d4d)  appearing as it is

Expected results:
virma should join with character to appear as Chillu character (combined glyph)

Additional info:
Screenshot!
Comment 1 A S Alam 2007-12-13 05:14:06 EST
Created attachment 287281 [details]
ml_IN
Comment 3 A S Alam 2007-12-13 05:35:57 EST
Created attachment 287291 [details]
Screenshot for Both Actual and Expected
Comment 4 Rahul Bhalerao 2008-01-17 08:51:23 EST
This problem has occurred due to changes done in Pango upstream.To fix this the
ZWJ flag in Pango should be changed. Reassigning the bug component to Pango.
Comment 5 Behdad Esfahbod 2008-01-23 13:54:21 EST
Rahul, is this filed upstream?  Please file if it's not.  Helps if you can point
out which commit broke it...  Thanks.
Comment 6 Rahul Bhalerao 2008-01-30 05:40:56 EST
Behdad, there is a bug filed upstream in gnome bugzilla #504810. This bug is
though filed for Samvruthokaram issue, the patch given there by Praveen also
includes a fix for Chillu issue. The related commit was done in the bug #357790
upstream due to the patch in the comment #14, that removed the flag
'SF_PROCESS_ZWJ'. 
Thanks.
Comment 7 Rahul Bhalerao 2008-03-10 03:38:43 EDT
This bug is fixed upstream in the version pango-1.19.4. Fixed in rawhide,
pango-1.19.4-1.fc9

Note You need to log in before you can comment on or make changes to this bug.