Bug 423181 - libid3tag-devel should require zlib-devel
libid3tag-devel should require zlib-devel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libid3tag (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Todd Zullinger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 06:12 EST by W. Michael Petullo
Modified: 2007-12-13 07:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-13 07:01:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2007-12-13 06:12:47 EST
Description of problem:
The id3tag library requires zlib. However, the libid3tag-devel package does not
require zlib-devel.

Version-Release number of selected component (if applicable):
libid3tag-devel-0.15.1b-4.fc8

How reproducible:
Everytime

Steps to Reproduce:
1. Install libid3tag-devel, but ensure zlib-devel is not installed. Note that
building against libid3tag fails.
  
Actual results:


Expected results:


Additional info:
>  ldd /usr/lib/libid3tag.so
        linux-vdso32.so.1 =>  (0x00100000)
        libz.so.1 => /lib/libz.so.1 (0x6ff92000)
        libc.so.6 => /lib/libc.so.6 (0x6fdee000)
        /lib/ld.so.1 (0x20000000)
Comment 1 Hans de Goede 2007-12-13 07:01:32 EST
This is not a bug in libid3tag, but in whatever you are trying to build, I
assume it adds -lz to the LDFLAGS, this is not in libid3tag's pkgconfig file,
nor does libid3tag's public headers require any zlib headers, so there is no
reason for libid3tag-devel to require zlib-devel, as when done properly
compiling against libid3tag can be done fine without zlib-devel installed.

Note You need to log in before you can comment on or make changes to this bug.