Bug 423211 - [ml_IN] combination is Incorrect with 0d30 [consonant+0d4d+0d30]
Summary: [ml_IN] combination is Incorrect with 0d30 [consonant+0d4d+0d30]
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: icu   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: i18n, Reopened
Depends On: 423191
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-13 11:30 UTC by A S Alam
Modified: 2013-07-03 00:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-31 07:52:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot for the current problem (103.81 KB, image/png)
2008-01-25 06:13 UTC, Ani Peter
no flags Details

Description A S Alam 2007-12-13 11:30:27 UTC
+++ This bug was initially created as a clone of Bug #423191 +++

Description of problem:
combination is correct with 0d30 [consonant+0d4d+0d30]

Version-Release number of selected component (if applicable):
fonts-malayalam-2.1.5-3.fc8
pango-1.19.1-1.fc9
libicu-3.8-5.fc9
qt-3.3.8-11.fc9
qt4-4.3.3-1.fc9


How reproducible:
Everytime

Steps to Reproduce:
1. open gedit/kate/oowriter
2. type rawcode with SCIM 
3. 0d15+0d4d+0d30
  
Actual results:
No combine as expected

Expected results:
should have glyph as showing in image with Openoffice or kedit (but before
instead of end of character)

Additional info:
Image attached with Three (rendering system)
gedit - 
kate - QT4
openoffice-writer-icu

-- Additional comment from aalam@redhat.com on 2007-12-13 06:29 EST --
Created an attachment (id=287321)
SCreenshot with kate/oowriter/gedit

Comment 1 A S Alam 2007-12-13 11:33:23 UTC
Problem in this component is "combined character should be before instead of end
of character"

Comment 2 Caolan McNamara 2007-12-13 13:03:19 UTC
RA 0xd30 is categorized different to RRA 0xd31, so it has a "hasPostBaseForm" so
the baseConsonant value goes to 0 so the swap hack we use doesn't trigger. If I
recatagorize 0D30 from _pb to _cn the it is treated the same and I get what you
want.

Of course I have no idea if that is the right fix, and it probably isn't.
Alternatively the swap hack might be modified someway to work a little
differently to pick up this issue.

Comment 3 Caolan McNamara 2007-12-13 14:57:13 UTC
I'll try a hideous horrible hack. At least all existing malayalam test cases
continue to work. But I have my doubts about the original hack as well as this
extension and the font itself. Someone should probably have a look at the new ms
malayalam font and see if that works too for our current testcase or if we're
writing specifically for a single broken font.

Anyway give icu-3.8-6.fc9 a go and see that does what you expect.

Comment 4 Caolan McNamara 2007-12-14 08:15:35 UTC
Can I please have
http://batman.brisbane.redhat.com/~indic/IndicTC/lang/ml_IN/font/IndicFontTestCaseGSUB-Malayalam.html
updated to include this new combination with a screenshot/drawing of what is
considered the canonical correct version.

Comment 5 A S Alam 2008-01-14 07:39:32 UTC
it is fixed, tested with following package:
icu-3.8-6.fc9

Comment 6 Ani Peter 2008-01-25 06:11:35 UTC
Hi,

The problem with 0D30 still exists.
Tested with icu-3.8.1-2.fc9

 The actual glyph is not yet formed. Instead of forming a half bracket kind of
symbol before the consonant 0D15, 0D30 appears before 0D15. Any consonant from
0D15 - 0D39 (except 0D30 and 0D31) + 0D4D + 0D30 must give the result as the
half bracket symbol appearing before the consonant.

Hence re-opening the bug
Screen shot attached. 

Thanks
Ani


Comment 7 Ani Peter 2008-01-25 06:13:31 UTC
Created attachment 292912 [details]
Screenshot for the current problem

Comment 8 Caolan McNamara 2008-01-25 09:05:20 UTC
hmm, seems to have gotten broken with 3.8.1 for some reason

Comment 9 Caolan McNamara 2008-01-25 13:12:52 UTC
Gotcha I think. Please try to update test-cases to include the examples intended
to be fixed here.

Comment 10 Ani Peter 2008-01-28 04:40:31 UTC
I have reveiwed and reported the updations to be made in the test cases. QE team
is in the process of preparing the final test case for Malayalam and will be
ready by this week

Thanks
Ani

Comment 11 Ani Peter 2008-01-31 07:38:38 UTC
Hi,

Tested on icu-3.8.1-3.fc9. This bug is fixed in this.

Thanks
Ani


Note You need to log in before you can comment on or make changes to this bug.