Bug 423261 - pppd and selinux
Summary: pppd and selinux
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: 8
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-13 12:24 UTC by Leszek Matok
Modified: 2007-12-13 16:04 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-13 16:04:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg chunk (2.15 KB, application/octet-stream)
2007-12-13 12:24 UTC, Leszek Matok
no flags Details
ifcfg-ppp0 (250 bytes, application/octet-stream)
2007-12-13 12:25 UTC, Leszek Matok
no flags Details

Description Leszek Matok 2007-12-13 12:24:11 UTC
I use the most popular Polish Internet service, which is neostrada tp. Instead
of following stupid webpages about "how to set it up under Linux" (which deal
with it the Slackware way, being very intrusive to the system), I've used
Fedora's startup scripts. It works great and I'm using it since FC6 or 5. The
only thing that's bothering me are the "avc: denied" messages :)

I've told you all that, because in my opinion I'm not doing anything non-Fedora
way. I'm just using some non-standard config file, which I'll attach in a moment.

I'm attaching:

- dmesg fragment that gets there after "ifup ppp0",
- my ifcfg-ppp0 if it can help nail the problem.

Once again, everything works (or pretends to be working for over a year), so
it's a cosmetic issue.

Comment 1 Leszek Matok 2007-12-13 12:24:11 UTC
Created attachment 287361 [details]
dmesg chunk

Comment 2 Leszek Matok 2007-12-13 12:25:39 UTC
Created attachment 287371 [details]
ifcfg-ppp0

Comment 3 Daniel Walsh 2007-12-13 16:04:35 UTC
There is a boolean for this

setsebool -P pppd_can_insmod 1




Note You need to log in before you can comment on or make changes to this bug.