Bug 423461 - Default System Groups not bold in list
Default System Groups not bold in list
Status: CLOSED WORKSFORME
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Orazi
Amy Owens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 09:38 EST by Patrick C. F. Ernzer
Modified: 2008-02-05 14:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 13:02:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2007-12-13 09:38:13 EST
Description of problem:
at https://rhn.redhat.com/rhn/users/AssignedSystemGroups.do?uid=SOMETHING
we say "Current default System Groups are bold", at least on this box they are not.


Version-Release number of selected component (if applicable):
Red Hat Network release 5.0.4

How reproducible:
always


Steps to Reproduce:
1. log in to RHN
2. go to https://rhn.redhat.com/rhn/users/ActiveList.do
3. select a user
4. click System Groups to go to
https://rhn.redhat.com/rhn/users/AssignedSystemGroups.do?uid=SOMETHING
5. in my case select an Assigned System Groups on the second page of the list
(not sure if this matters)
6. Click Update Permissions
7. go to second page again, select the group you just assigned under Default
System Groups
8. Click Update Defaults
  
Actual results:
default system group I have just selected is not bold


Expected results:
default system group is bold


Additional info:
this is a fairly large org account where each user has his own system group and
I assign that as the default group.
Comment 1 Bill C. Riemers 2008-01-22 11:26:52 EST
None of the users I tried had more than one page of System Groups, but that did
not seem to matter, the bug still reproduced normally.

Additionally, after reproducing this bug, I find I can no-longer check Assigned
System Groups.  Were previously there were check boxes, there is now the text
[Admin Access].  The Click Update Permissions button is no longer visible. 
Logging out and back in did not fix this problem.


Comment 2 Bill C. Riemers 2008-01-22 13:02:38 EST
Looks like I had produced a different bug.  I can not seem to reproduce this
bug.  Here are the steps I followed:

1. Login to rhn.  As prep work, add a normal user for testing, and create enough
groups, that the group list scrolls to the second page.
2. Click on the user.
3. Click on System Groups.
4. Click to the second page of groups.
5. Select a group on the second page.
6. Click on Assign System Groups.
(NOTE: I am still at the second page when this completes.)
7. Click to the first page, and then back to the second page.
8. Select the group I just assigned under Default Groups.
9. Click Update Defaults.

After these steps, the default is bold.  I tried several different variations of
these steps, and the default is always bold.  Provided you are on the page
displaying the default.
Comment 3 Patrick C. F. Ernzer 2008-01-22 13:37:38 EST
yes, it seems to have gone away.

Note You need to log in before you can comment on or make changes to this bug.