Bug 423541 - how can i force editing of the shadow password file?
how can i force editing of the shadow password file?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 10:17 EST by Andrew Cagney
Modified: 2008-05-13 09:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 09:32:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Cagney 2007-12-13 10:17:04 EST
I, due to another problem, needed to edit the shadow password file; but vipw on
its own without edits won't touch it.

Can at least an option be added to let me do this.

(oh, and what does the -V option do? the man page mentions it but doesn't
explain it)
Comment 1 Karel Zak 2008-01-07 07:02:20 EST
The -V option is synonym of --version.

vipw(8) asks for shadow password file after you make a change to the standard
/etc/passwd. Or do you need to edit only /etc/shadow?

(Note, I won't to add any new option to vipw(1) from util-linux-ng. This command
is deprecated in favor of vipw from shadow-utils in Fedora 9.)
Comment 2 Andrew Cagney 2008-01-07 12:05:08 EST
I only need to edit the shadow password file.
Comment 3 Peter Vrabec 2008-05-13 09:32:18 EDT
Andrew, I'm sorry I won't add any new option. You can edit shadow right after 
you quit passwd by ":wq". If you are not OK with this, feel free to open 
discussion on pkg-shadow-devel@lists.alioth.debian.org

Note You need to log in before you can comment on or make changes to this bug.