Bug 4236 - elf_prstatus via procfs.h differs from kernel
elf_prstatus via procfs.h differs from kernel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-28 04:32 EDT by jcownie
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jcownie 1999-07-28 04:32:25 EDT
On Red Hat 6.0 on the Alpha processor (kernel 2.2.3), there
seems to be an inconsistency between
the file elfcore.h (which defines elf_prstatus) and the
kernel (which dumps an elf_prstatus into
a note in the core file).

When one compiles a trivial code which prints the sizeof
(struct elf_prstatus),
one gets the result 352, however the size of the NOTE in a
core file (which is
set by the kernel to be sizeof (elf_prstatus) is 384.

The inconsistency appears to be caused by an extra 32 bytes
of something
somewhere before the pr_reg structure, since one can easily
write a program
to put known values in the registers and then core dump,
allowing one to see
where the registers appear...

Note You need to log in before you can comment on or make changes to this bug.