Bug 4239 - ispell reverts local dictionary to American English upon upgrade 5.2 -> 6.0
ispell reverts local dictionary to American English upon upgrade 5.2 -> 6.0
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ispell (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-28 12:08 EDT by David Woodhouse
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-19 17:30:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 1999-07-28 12:08:46 EDT
Having installed British versions of the ispell and words
packages, they were overwritten with the American version
when I upgraded to RH6.

ispell needs to be provided with local distionaries, and
some way of retaining the desired settings across an
upgrade.
Comment 1 Jeff Johnson 1999-09-06 13:15:59 EDT
FWIW I've added the British dictonary to ispell, although the
English dictionary is still American. AFAIK a couple of symlinks
should permit you to change the deafulat English to British.

If you send a pointer/copy of British /usr/dict/words, I will try to
include a locale specific /usr/dict/words.

Adding support for local dictionaries seems barely worth the effort
at this time. Pleases send a pointer to a better dictionary for
inclusion in the ispell package instead.

------- Additional Comments From   09/20/99 12:26 -------
An SRPM of British words is in the libc5 contrib. If this is what
you've included in ispell, then I don't know of anything better.
That's been good enough for us for some time, though.

It's not really the lack of UK dictionaries that I considered a bug,
but the fact that after I'd gone to the trouble of finding and
installing them, the RH6 upgrade removed them again for me. Perhaps
they should be marked as config files?

I've now just ditched ispell and replaced it with aspell - which is
possibly a good solution for Lorax, too. It allows fairly simple
system-wide and/or user configuration of dictionaries, and I believe
it also has separate language dictionaries in separate RPMS, which
have would fixed my original problem.
Comment 2 Michael K. Johnson 1999-11-19 17:30:59 EST
Since we now install many different dictionaries, including british,
this should have been a one-time inconvenience.

Note You need to log in before you can comment on or make changes to this bug.