Bug 42392 - Anaconda error after Package Dependencies but before X Configurator in Anaconda.
Anaconda error after Package Dependencies but before X Configurator in Anaconda.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-26 19:37 EDT by Jeff Coe
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-26 15:15:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Coe 2001-05-26 19:37:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows Me; Win 9x 4.90)

Description of problem:
In anaconda, i am in a custom installation where i am choosing my 
packages.  After anaconda checks for all of the package dependencies, it 
gives me an error.  This happens before the X Configurator pops up in 
Anaconda.

How reproducible:
Always

Steps to Reproduce:
1. Pick the X Window System Package and the KDE Package
2. Wait for package dependencies checker to check the packages
3. Error comes up before the X Configurator comes up
	

Actual Results:  Anaconda Traceback Error:

Traceback (innermost last):
     File "usr/bin/anaconda", line 438, in ?
          intf.run(todo, test = test)
     File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py" , line 1030, in run
     rc = apply(step[1](),step[2])
     File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 391, in __call__
     carddb = todo.x.cards()
     File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/xf86config.py", line 660, in 
cards
     lines = db.readlines()
IOError: [Errno 5] Input/Output Error



Expected Results:  It should have brought me up to the X Configurator 
screen.

Additional info:

Anaconda Traceback Error:

Traceback (innermost last):
     File "usr/bin/anaconda", line 438, in ?
          intf.run(todo, test = test)
     File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py" , line 1030, in run
     rc = apply(step[1](),step[2])
     File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 391, in __call__
     carddb = todo.x.cards()
     File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/xf86config.py", line 660, in 
cards
     lines = db.readlines()
IOError: [Errno 5] Input/Output Error
Comment 1 Brent Fox 2001-05-29 14:39:56 EDT
I think that you have a bad cd.  Can you look on VC3 and VC4 and see if there
are any error messages about reading the cd?
Comment 2 Jeff Coe 2001-05-29 16:01:19 EDT
"From bfox@redhat.com:
+I think that you have a bad cd.  Can you look on VC3 and VC4 and see if there
+are any error messages about reading the cd?"

What do you mean by VC3 and VC4? (I am new to linux) I also forgot to mention 
that i am installing this on a 486 AMD Processor, 24MB of RAM, and a hard drive 
with 519MB (Paritions are / root 419MB and swap partition is 100MB).
Comment 3 Jeff Coe 2001-05-29 16:04:10 EDT
One more thing i also forgot to mention, i downloaded this from ftp.redhat.com 
and i also burned it to a cd. the cd has no scratches on it so i have no idea 
what could be the problem.
Comment 4 Brent Fox 2001-05-31 14:53:08 EDT
The official minimum memory requirements are 32MB of memory, but I think that
you might be able to get it to work with 24MB.  Anything less than 20MB is
probably not going to work, though.  

I think that something might have gotten corrupted during the download.  VC3 and
VC4 means "Virtual terminals #3 and #4".  You can access them pressing
<Ctrl><Alt><F3> and <Ctrl><Alt><F4>.  We send debug messages to those screens. 
To get back to the installer screen, press <Ctrl><Alt><F1>.  I assume that you
are doing a text mode install...the graphical installer takes more than 24MB of
memory in order to run.

If there are errors with the cd, there will usually be error messages on VC3 or
VC4 about "cdrom seek errors" or something like that.  If you see that, then
your download of Red Hat Linux probably got messed up somehow.
Comment 5 Jeff Coe 2001-06-02 17:49:04 EDT
Ok this is what the VC3 says:
probing for ide floppies
no ide floppies found
looking for usb controllers
no usb controllers found
looking for video cards requiring agpgart module
no video cards found
tying to mount device hdb
loopfd is 6
found url image cdrom://hdb/mnt/source
getting ready to spawn shell now
going to ins mod raid0.o (path is NULL)
going to ins mod raid1.o (path is NULL)
going to ins mod raid5.o (path is NULL)
going to ins mod fat.o (Path is NULL)
going to ins mod vfat.o (Path is NULL)
going to ins mod ext3.o (Path is NULL)
looking for usb mouse
no ide floppy devices found

VC4 had lots of things about sectors and other stuff,it was a lot to write down 
so i didnt, but inbetween the numbers it said attempt to access beyond end of 
device.

Also, I do know that my floppy drive works, i dont know why it said no ide 
floppy devices found....thats how i got into the Linux setup. What i do to 
start the setup is i put a Windows Me startup disk and then it comes up with 
the prompt:

C:\> then i go to D:\> and i go to D:\Dosutils> then i type in autoboot.bat and 
it loads. 

Do you know what the problem is?
Comment 6 Brent Fox 2001-06-04 13:15:50 EDT
Can you try booting with 'linux ide=nodma noprobe' and see if that works?  The
messages on VC4 makes it sound like the kernel is having some problem reading
either the hard drive or the cdrom, but without the exact messages, I can't say
for sure.
Comment 7 Jeff Coe 2001-06-04 18:39:53 EDT
how would i do that? i boot the setup from DOS and not Linux.  Linux isnt 
installed on my computer..it's just the setup program.
Comment 8 Brent Fox 2001-06-11 11:07:51 EDT
When you boot the computer with the Red Hat Linux disc 1 in the machine, you
should see a bootup screen that says "Welcome to Red Hat Linux 7.1!" at the top.
At this screen, type in 'linux ide=nodma noprobe' and press Enter.  

Comment 9 Jeff Coe 2001-06-12 11:53:24 EDT
well, i dont see that, my BIOS is kind of out of date it doesnt boot from a CD-
ROM, so i have to go into DOS and load it. It just takes me to anaconda, the 
blue screen and it asks me if i have a driver disc
Comment 10 Brent Fox 2001-06-13 13:49:46 EDT
Then, I'd recommend making a boot disk with the boot.img file in the /images
directory of the cdrom and then booting off that boot disk.  Type in 'linux
ide=nodma noprobe' when the bootup screen appears.  Put your cdrom in the drive
and then the boot disk will access it.
Comment 11 Jeff Coe 2001-06-13 14:43:35 EDT
how would i boot the floppy? it keeps telling me it is not a system disk
Comment 12 Brent Fox 2001-06-14 09:53:08 EDT
Sounds like something is wrong with either the floppy disk or the boot.img file
you made it with.  Anytime you see the non system disk message, it means that
something is not right with the floppy.  The correct behavior should be that the
system boots off the floppy and presents you with a "Welcome to Red Hat Linux"
screen.

What was the command you used to make the boot disk?
Comment 13 Jeff Coe 2001-06-14 09:59:37 EDT
I used Winimage on Windows Me, should i use rawrite.exe? it just copied system 
files onto the disk. The hard drive i am installing Red hat linux with has 
nothing on it. i just use a windows startup disk (which brings me into dos) to 
install linux. so, should i use rawrite next time?
Comment 14 Brent Fox 2001-06-14 16:07:03 EDT
Yes, try rawrite.
Comment 15 Jeff Coe 2001-06-14 18:18:20 EDT
when i try to boot it says Boot Failed: Insert another disk and press any key 
to continue. this always happens after it tries to load initrd.img. I also 
tried downloading boot.img again from a FTP site and make a disk from there. 
That didnt work.
Comment 16 Brent Fox 2001-06-15 10:46:04 EDT
Do you still have the ISO's that you used to make the cd's with?  I'm inclined
to believe that you have a bad cd.  You can use a program MD5Sumer to check the
md5sum on the ISO to verify that nothing got corrupted during the download.

MD5Sumer can be found at
http://cnet.com/downloads/0-10096-100-5902737.html?tag=st.dl.10000-103-1.lst-7-1.5902737

The md5sums should match:
fc9c2c23b02d2a35b75845530db81743  7.0-respin-disc1.iso
0e77615754f281363c231b2d4b1806bb  7.0-respin-disc2.iso


If the numbers that you get from md5sumer are different, then something got
scrambled when you were downloading.  Actually, I would recommend trying 7.1 if
you have the time/bandwidth to download it.
Comment 17 Jeff Coe 2001-06-15 13:10:07 EDT
well, the CD's came up ok. Nothing is wrong with them. I only have a 56k 
connection and it took me a while to get 7.0, so i dont really want to do that 
again. Any other ideas that would work?
Comment 18 Jeff Coe 2001-06-16 16:18:10 EDT
i also got the boot disk to work. i can boot from the red hat linux 7.0 disc to 
the setup program. is there any commands i could type in where it says boot: to 
make the setup not give me that error?
Comment 19 Jeff Coe 2001-06-16 20:34:32 EDT
I tried the 'linux ide=nodma noprobe' and i looked at VC3 and nothing happened. 
everything stayed the same.  I typed it in where it said 'Welcome to Red Hat 
Linux 7.0!' at the top when the boot disk loaded. so it looked like this 'boot: 
linux ide=nodma noprobe'. Nothing happened there. Any suggestions?
Comment 20 Brent Fox 2001-06-19 11:10:10 EDT
After you typed in 'linux ide=nodma noprobe', did you press Enter?  The bootup
process should start after pressing Enter.
Comment 21 Jeff Coe 2001-06-19 11:48:25 EDT
Yes, the the Linux setup started and everything, but i meant that it still 
probed and found the floppy drive and still gave me the error.
Comment 22 Jeff Coe 2001-06-22 17:50:45 EDT
I also wanted to tell you that i tried installing Red Hat Linux 7.0 on another 
computer (Intel Pentium 133Mhz, 80MB of RAM, 1.26GB Hard drive) and it gave me 
the same error. It also could not find the floppy drive.
Comment 23 Brent Fox 2001-06-26 14:13:00 EDT
I can't explain why this would happen.  Is the floppy drive enabled in the BIOS?
Comment 24 Jeff Coe 2001-06-26 15:15:39 EDT
Yes, the floppy drive is enabled. Do you think there is an error in the 
programming code?
Comment 25 Brent Fox 2001-06-26 18:43:11 EDT
There could be, but I don't think so.  I test booting off of floppy disks every
day, so I know that this works.  As to why this doesn't work on your machine...I
just don't know.  I'm out of ideas.
Comment 26 Jeff Coe 2001-06-26 18:51:17 EDT
what program do Red Hat or just Linux professionals use to make a Linux CD from 
the ISO file?
Comment 27 Brent Fox 2001-06-26 19:01:26 EDT
cdrecord is a command line program to burn cdroms.  There are graphical
applications such as GCombust and XCDRoast that are GUI interfaces to cdrecord.
Comment 28 Jeff Coe 2001-06-26 19:06:02 EDT
Well, what programs would run in Windows? I have never used Linux before. Plus, 
i am only 15 years old, so, i'm only learning. I don't know a lot about Linux 
commands.
Comment 29 Brent Fox 2001-06-27 01:15:05 EDT
Well, I haven't used Windows in years, so I don't know what people are using in
Windows to burn cd's these days.  I used to use the Sony CDRight! that came with
my burner about four years ago.  Basically, I think any cdrom burning program
would work fine for burning the ISOs.

In linux, you can burn a cd with cdrecord with a command like:
'cdrecord -dev=0,0,0 seawolf-disc1.iso'   where '-dev=0,0,0' is the device
number of the cd burner on the IDE bus.
Comment 30 Jeff Coe 2001-06-27 07:48:26 EDT
Ok i'll try re-burning the CD with another program. If that doesn't work, my 
friend just got Red Hat Linux 6.2, so i will put that on instead. Thanks a lot 
for your help!

Note You need to log in before you can comment on or make changes to this bug.