Bug 42395 - smb.conf file has odd crap in it that cause spurious errors
smb.conf file has odd crap in it that cause spurious errors
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-26 20:54 EDT by Seth Vidal
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-26 20:54:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seth Vidal 2001-05-26 20:54:18 EDT
Description of Problem:
run any samba-related command on a system with the default smb.conf file
and you get:

$ smbpasswd
Unknown parameter encountered: "ssl CA certFile"
Ignoring unknown parameter "ssl CA certFile"

it seems to be due to the fact that samba is no longer built with the silly
ssl support turned on.


this should be commented out of the smb.conf file in /etc/samba


the section says this:
# The following is needed to keep smbclient from spouting spurious errors
# when Samba is built with support for SSL.
   ssl CA certFile = /usr/share/ssl/certs/ca-bundle.crt

this is kinda a lie :)


How Reproducible:
always



Steps to Reproduce:
1. run smbclient
2. run smbpasswd
3. run testparm


thats all
Comment 1 Trond Eivind Glomsrxd 2001-06-19 10:07:54 EDT
This is commented out in 2.2.0-1

Note You need to log in before you can comment on or make changes to this bug.